Bug 48708 - Excel: Custom Paper size (height/Width)
Summary: Excel: Custom Paper size (height/Width)
Status: RESOLVED DUPLICATE of bug 48707
Alias: None
Product: POI
Classification: Unclassified
Component: XSSF (show other bugs)
Version: unspecified
Hardware: All All
: P2 major (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on: 48707
Blocks:
  Show dependency tree
 
Reported: 2010-02-08 23:41 UTC by Tariq Zubairy
Modified: 2010-05-30 03:07 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tariq Zubairy 2010-02-08 23:41:43 UTC
+++ This bug was initially created as a clone of Bug #48707 +++

HSSFPrintSetup/XSSFPrintSetup setPaperSize method does not allow to set custom width and custom height of paper used for printing ...

Here is my scenario...

HSSFSheet hssfSheet = hssfWorkBook.getSheetAt(0);
HSSFPrintSetup hssfPS = hssfSheet.getPrintSetup();

hssfPS.setFitWidth((short)1);
hssfPS.setFitHeight((short)999);
hssfSheet.setFitToPage(true);


here I want to set the custom paper size, as setPaperSize only gives few option for paper size so it is not feasible due to that limitation. I want to set the custom paper size according to the maximum physical number of cells in excel sheet so that the data in my sheet should not shrink when I made its actual printout or PDF.... (i.e. set width to 17 inches when max physical columns in sheet are more than 10 and set width of page to 20 inches when max physical columns are greater than 15 etc...)
Comment 1 Yegor Kozlov 2010-03-15 06:45:24 UTC

*** This bug has been marked as a duplicate of bug 48770 ***
Comment 2 Tariq Zubairy 2010-03-15 06:55:24 UTC
Unable to understand why this is marked as duplicate of https://issues.apache.org/bugzilla/show_bug.cgi?id=48770
Comment 3 Yegor Kozlov 2010-05-30 03:07:22 UTC

*** This bug has been marked as a duplicate of bug 48707 ***