Bug 48823 - Recognize -- to signal end of options and beginning of target names
Summary: Recognize -- to signal end of options and beginning of target names
Status: RESOLVED DUPLICATE of bug 24231
Alias: None
Product: Ant
Classification: Unclassified
Component: Core (show other bugs)
Version: 1.8.0
Hardware: All All
: P2 enhancement (vote)
Target Milestone: ---
Assignee: Ant Notifications List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-26 14:19 UTC by Jesse Glick
Modified: 2010-02-26 15:15 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2010-02-26 14:19:36 UTC
All getopt-based tools permit -- to be placed in a command's argument list to indicate that all options have been passed and that further arguments are "regular" items such as filenames.

In the case of Ant, any subsequent items should be interpreted as target names.

This would allow expert users to invoke targets whose name begins with a dash. Conventionally these should be hidden, but on occasion you want to run them e.g. to test that they function correctly, even when in normal usage they should only ever be called from another target.

It would also be useful from scripts or IDEs that launch Ant using the command line (rather than embedded) and want to pass a specific list of targets without fear of some of them being misinterpreted as options.
Comment 1 Matt Benson 2010-02-26 15:15:40 UTC

*** This bug has been marked as a duplicate of bug 24231 ***