Bug 48862 - AJP Connector ignores Backlog configuration parameter
AJP Connector ignores Backlog configuration parameter
Status: RESOLVED FIXED
Product: Tomcat 6
Classification: Unclassified
Component: Connectors
unspecified
PC Linux
: P2 normal (vote)
: default
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2010-03-05 01:03 UTC by Tyler Vallillee
Modified: 2010-04-07 22:07 UTC (History)
0 users



Attachments
Patch against trunk revision 919249 (1.19 KB, application/octet-stream)
2010-03-05 01:03 UTC, Tyler Vallillee
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tyler Vallillee 2010-03-05 01:03:39 UTC
Created attachment 25085 [details]
Patch against trunk revision 919249

The AJP/JK ChannelSocket connector ignores the backlog configuration parameter. The current behavior is that the JDK default will be used.

Because the JDK default is quite low, it is possible for Tomcat to get into a state where the queue of waiting connections is exhausted prematurely. 

This bug is a regression from Tomcat 5 Bug 38332.

Patch attached.
Comment 1 Mark Thomas 2010-03-29 13:25:49 UTC
This was added to Tomcat 5.5.x in r493480. I have proposed porting this patch to Tomcat 6.0.x.

Note that this code was removed from trunk for Tomcat 7.
Comment 2 Mark Thomas 2010-04-07 22:07:04 UTC
This has been fixed in 6.0.x and will be included in 6.0.27 onwards.