Bug 48878 - OutOfMemory during endurance testing
Summary: OutOfMemory during endurance testing
Status: RESOLVED WONTFIX
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.3.4
Hardware: All Windows XP
: P2 major (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL: out of memory error
Keywords: ErrorMessage
Depends on:
Blocks:
 
Reported: 2010-03-09 13:41 UTC by Philippe Mouawad
Modified: 2010-07-08 19:24 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Mouawad 2010-03-09 13:41:13 UTC
Hello,
Load testing an application, we get an error on some kind of content.
This happends any time during the test (10 Users or 300 or 1500).
I think this is due to corrupt response.

Monitoring memory, this does not happen when JMeter is high (when it happened for example Used Heap was 100 Mo while available heap was 2GO)

I encountered this kind of error on a project on which I also used deflating so I think it comes from here.


Cordially
Philippe
http://www.ubik-ingenierie.com

StackTrace:
2010/03/09 11:33:05 ERROR - jmeter.threads.JMeterThread: Test failed! java.lang.OutOfMemoryError
	at java.util.zip.Inflater.inflateBytes(Native Method)
	at java.util.zip.Inflater.inflate(Inflater.java:223)
	at java.util.zip.InflaterInputStream.read(InflaterInputStream.java:135)
	at java.util.zip.GZIPInputStream.read(GZIPInputStream.java:92)
	at java.io.BufferedInputStream.read1(BufferedInputStream.java:256)
	at java.io.BufferedInputStream.read(BufferedInputStream.java:317)
	at java.io.FilterInputStream.read(FilterInputStream.java:90)
	at org.apache.jmeter.protocol.http.sampler.HTTPSamplerBase.readResponse(HTTPSamplerBase.java:1462)
	at org.apache.jmeter.protocol.http.sampler.HTTPSampler.readResponse(HTTPSampler.java:288)
	at org.apache.jmeter.protocol.http.sampler.HTTPSampler.sample(HTTPSampler.java:516)
	at org.apache.jmeter.protocol.http.sampler.HTTPSamplerBase.downloadPageResources(HTTPSamplerBase.java:1118)
	at org.apache.jmeter.protocol.http.sampler.HTTPSamplerBase.resultProcessing(HTTPSamplerBase.java:1317)
	at org.apache.jmeter.protocol.http.sampler.HTTPSampler.sample(HTTPSampler.java:580)
	at org.apache.jmeter.protocol.http.sampler.HTTPSamplerBase.sample(HTTPSamplerBase.java:961)
	at org.apache.jmeter.protocol.http.sampler.HTTPSamplerBase.sample(HTTPSamplerBase.java:947)
	at org.apache.jmeter.threads.JMeterThread.process_sampler(JMeterThread.java:348)
	at org.apache.jmeter.threads.JMeterThread.run(JMeterThread.java:243)
	at java.lang.Thread.run(Thread.java:619)
Comment 1 Philippe Mouawad 2010-03-09 20:38:58 UTC
Affected versions:
TRunk of 07/03/2010
Last released version:2.3.4
Comment 2 Philippe Mouawad 2010-03-10 19:40:44 UTC
I think bug is in JDK 6 Update 18.
It happens with Chunked response, on 404.

Philippe.
Comment 3 Sebb 2010-03-11 09:55:30 UTC
I don't think there's anything the JMeter code can do to protect against such occurrences.

Seems to me that this bug should be raised against Java, not JMeter.

However, if you can provide a simple test case that triggers the problem, that would be helpful.
Comment 4 nagarajan 2010-05-24 09:35:37 UTC
I am using thread group which contains java request samplers.I also use three Listeners, Table view, tree view and Summary report. 
When I do endurance testing, Jmeter throws out of memory error after 15 hrs of run.
I have also tried by increasing heap memory in jmeter.bat file, and disabling listeners except Summary report(which wont occupy much of jmeter memory)
Kindly give suggestions , how could I over come this issue.
Comment 5 Sebb 2010-05-24 09:41:18 UTC
(In reply to comment #4)
> I am using thread group which contains java request samplers.I also use three
> Listeners, Table view, tree view and Summary report. 
> When I do endurance testing, Jmeter throws out of memory error after 15 hrs of
> run.
> I have also tried by increasing heap memory in jmeter.bat file, and disabling
> listeners except Summary report(which wont occupy much of jmeter memory)
> Kindly give suggestions , how could I over come this issue.

This is a usage question, not a bug. Please ask on the JMeter user list.
Comment 6 Sebb 2010-07-08 19:24:11 UTC
Not possible to fix this in JMeter