Bug 48931 - Apache/Windows: Can't Install To "C:\Program Files (x86)"
Summary: Apache/Windows: Can't Install To "C:\Program Files (x86)"
Status: RESOLVED DUPLICATE of bug 47945
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: Core (show other bugs)
Version: 2.5-HEAD
Hardware: PC All
: P2 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-17 20:11 UTC by Axel
Modified: 2010-03-17 20:14 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Axel 2010-03-17 20:11:55 UTC
After installing the latest XAMPP/Windows to "C:\Program Files (x86)" everything went fine, except for Apache, which did not run.

This is what has been logged to the Windows Event Log when trying to start Apache as a service.

----------------------------------------------
    Protocol Name: System
    Source:        Service Control Manager
    Event ID:      7024
    Level:         Fehler
    Description:
    The service "Apache2.2" was stopped due to following service specific error: Invalid function..
    Event XML:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Service Control Manager" Guid="{555908d1-a6d7-4695-8e1e-26931d2012f4}" EventSourceName="Service Control Manager" />
        <EventID Qualifiers="49152">7024</EventID>
        <Version>0</Version>
        <Level>2</Level>
        <Task>0</Task>
        <Opcode>0</Opcode>
        <Keywords>0x8080000000000000</Keywords>
        <TimeCreated SystemTime="2010-03-17T17:11:03.518774200Z" />
        <EventRecordID>1095</EventRecordID>
        <Correlation />
        <Execution ProcessID="460" ThreadID="884" />
        <Channel>System</Channel>
        <Computer>W2k8R2</Computer>
        <Security />
      </System>
      <EventData>
        <Data Name="param1">Apache2.2</Data>
        <Data Name="param2">%%1</Data>
      </EventData>
    </Event>
----------------------------------------------


This is the content from the error.log:

----------------------------------------------
    Syntax error on line 505 of C:/Program Files (x86)/xampp/apache/conf/httpd.conf:
    SSLSessionCache: Invalid argument: size has to be >= 8192 bytes
----------------------------------------------


It seems this is a known bug, because a workaround for this can be found at:

http://arfore.com/2009/08/24/sslsessioncache-error-on-apache-for-windows/


I couldn't find an existing bug in Bugzilla, so I'd like to bring this issue to your attention.
Comment 1 Eric Covener 2010-03-17 20:14:32 UTC

*** This bug has been marked as a duplicate of bug 47945 ***