Bug 48951 - Cannot build BCEL on Windows
Cannot build BCEL on Windows
Status: RESOLVED DUPLICATE of bug 49333
Product: BCEL - Now in Jira
Classification: Unclassified
Component: Main
5.3
PC Windows Vista
: P2 normal
: ---
Assigned To: issues@commons.apache.org
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2010-03-21 04:15 UTC by Daniel Bell
Modified: 2010-05-24 19:35 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Bell 2010-03-21 04:15:06 UTC
Attempted to build trunk at r925722 on Windows, but couldn't, due to test failures.

Windows version: Vista (64 bit)
Maven Version: 2.2.1
Java Version: 1.6.0_16 (64 bit)

Tests failed when asserting that file.delete() returned true. i.e. file cleanup during tests failed to delete files. The build worked on:

Solaris:
Maven Version: 2.2.1
Java Version: 1.4.2_11

Mac OSX:
Maven Version: 2.2.1
Java Version: 1.6.0_16
Comment 1 Daniel Bell 2010-03-21 04:17:03 UTC
(In reply to comment #0)
Minor correction to above:
Solaris build used Java version 1.6.0_06
Comment 2 Sebb 2010-05-24 19:35:42 UTC
No details of which tests failed, but I suspect it was GeneratingAnnotatedClassesTestCase which is solved by the patch in bug 49333

*** This bug has been marked as a duplicate of bug 49333 ***