Bug 49068 - UTF-8 URL Encode error
Summary: UTF-8 URL Encode error
Status: RESOLVED LATER
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: mod_proxy_http (show other bugs)
Version: 2.2.14
Hardware: PC Windows Server 2003
: P2 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords: MassUpdate
Depends on:
Blocks:
 
Reported: 2010-04-08 04:48 UTC by Xuefeng Wu
Modified: 2018-11-07 21:08 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xuefeng Wu 2010-04-08 04:48:44 UTC
When model_proxy_http handle url with Chinese  by UTF-8 character set, it encode incorrectly.
for example:
request url:
local/Rayco-%E9%99%88%E7%A7%80%E6%A2%85-20100329
proxy handled:
local:5080/Rayco-\xe9\x99\x88\xe7\xa7\x80\xe6\xa2\x85-20100329

When I use model_proxy_http 2.2.9, it work correctly.
Comment 1 Jeff Trawick 2010-04-08 14:20:12 UTC
You could find the exact 2.2.x release where the behavior changed.  (I can't tell from CHANGES what would have caused this change.  Are any other developers aware of recent changes related to URL encoding?)

Win32 binaries for 2.2.10-2.2.13 are available at http://archive.apache.org/dist/httpd/binaries/win32/
Comment 2 William A. Rowe Jr. 2018-11-07 21:08:05 UTC
Please help us to refine our list of open and current defects; this is a mass update of old and inactive Bugzilla reports which reflect user error, already resolved defects, and still-existing defects in httpd.

As repeatedly announced, the Apache HTTP Server Project has discontinued all development and patch review of the 2.2.x series of releases. The final release 2.2.34 was published in July 2017, and no further evaluation of bug reports or security risks will be considered or published for 2.2.x releases. All reports older than 2.4.x have been updated to status RESOLVED/LATER; no further action is expected unless the report still applies to a current version of httpd.

If your report represented a question or confusion about how to use an httpd feature, an unexpected server behavior, problems building or installing httpd, or working with an external component (a third party module, browser etc.) we ask you to start by bringing your question to the User Support and Discussion mailing list, see [https://httpd.apache.org/lists.html#http-users] for details. Include a link to this Bugzilla report for completeness with your question.

If your report was clearly a defect in httpd or a feature request, we ask that you retest using a modern httpd release (2.4.33 or later) released in the past year. If it can be reproduced, please reopen this bug and change the Version field above to the httpd version you have reconfirmed with.

Your help in identifying defects or enhancements still applicable to the current httpd server software release is greatly appreciated.