Bug 49076 - Skip document root check during start up (-T option)
Summary: Skip document root check during start up (-T option)
Status: RESOLVED DUPLICATE of bug 41887
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: Core (show other bugs)
Version: 2.2-HEAD
Hardware: All All
: P2 enhancement with 1 vote (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords: FixedInTrunk, PatchAvailable
Depends on:
Blocks:
 
Reported: 2010-04-09 00:00 UTC by Mike
Modified: 2010-07-20 09:16 UTC (History)
0 users



Attachments
Unified diff against apache-httpd 2.2.15 to provide trunk revision 893027 (4.03 KB, patch)
2010-04-09 00:00 UTC, Mike
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mike 2010-04-09 00:00:47 UTC
Created attachment 25248 [details]
Unified diff against apache-httpd 2.2.15 to provide trunk revision 893027

This is a request to backport trunk rev 893027 to Apache 2.2.(15) and to get this feature included in future 2.2.x releases.

Trunk revision:
http://svn.apache.org/viewvc?view=revision&revision=893027

Fix was filed as PR 41887,
https://issues.apache.org/bugzilla/show_bug.cgi?id=41887#c0

Short summary:
Add option to skip the documentroot check during httpd start.

Purpose:
Performance enhancement to httpd startup when slow/potentially unreachable media is used or if there is a large number of VirtualHosts configured.


Attached is the backport patch for Apache 2.2 (feel free to admire my ability to cut and paste).
Comment 1 Nick Kew 2010-07-20 09:16:11 UTC
Opening a new report isn't really the way to deal with this.  Either add to the existing report, or post to the dev list (the latter may work best if we've dropped the ball on a bug or RFE that matters to you).

*** This bug has been marked as a duplicate of bug 41887 ***