Bug 49153 - CTVectorVariant class missing from poi-ooxml-schemas.jar
CTVectorVariant class missing from poi-ooxml-schemas.jar
Status: RESOLVED FIXED
Product: POI
Classification: Unclassified
Component: POI Overall
3.7-dev
PC Windows XP
: P2 normal (vote)
: ---
Assigned To: POI Developers List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2010-04-19 11:21 UTC by Antoni Mylka
Modified: 2010-04-20 06:28 UTC (History)
0 users



Attachments
A patch that fixes the issue for me (5.60 KB, application/octet-stream)
2010-04-19 11:21 UTC, Antoni Mylka
Details
a test case, to be placed in test-data/document (13.07 KB, application/octet-stream)
2010-04-19 11:22 UTC, Antoni Mylka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Antoni Mylka 2010-04-19 11:21:36 UTC
Created attachment 25324 [details]
A patch that fixes the issue for me

As far as I understand the build.xml jar in POI the poi-ooxml-schemas jar is constructed by taking all the relevant classes from ooxml-schemas.1.0. This is done by a class called OOXmlLite, which runs the unit tests and looks which classes have been loaded.

Unfortunately the CTVectorVariant class doesn't seem to be referenced from any unit test, that is why it is not loaded to poi-ooxml-schemas.

I created a unit test class that uses the CTVectorVariant. This allows it to be discovered by OOXmlLite, The patch is attached.
Comment 1 Antoni Mylka 2010-04-19 11:22:32 UTC
Created attachment 25325 [details]
a test case, to be placed in test-data/document
Comment 2 Yegor Kozlov 2010-04-20 06:28:57 UTC
Fixed in r935860

Yegor