Bug 49333 - SyntheticRepository.loadClass() fails to close the inputStream
Summary: SyntheticRepository.loadClass() fails to close the inputStream
Status: RESOLVED FIXED
Alias: None
Product: BCEL - Now in Jira
Classification: Unclassified
Component: Main (show other bugs)
Version: unspecified
Hardware: PC Windows XP
: P2 normal
Target Milestone: ---
Assignee: issues@commons.apache.org
URL:
Keywords:
: 48951 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-05-24 13:25 UTC by Sebb
Modified: 2010-05-24 19:41 UTC (History)
1 user (show)



Attachments
Close input stream (803 bytes, patch)
2010-05-24 13:25 UTC, Sebb
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sebb 2010-05-24 13:25:58 UTC
Created attachment 25476 [details]
Close input stream

SyntheticRepository.loadClass() fails to close the inputStream.

This causes test problems (on Windows at least) because the class files are locked against deletion. And of course it may lead to resource exhaustion.
Comment 1 Sebb 2010-05-24 19:35:43 UTC
*** Bug 48951 has been marked as a duplicate of this bug. ***
Comment 2 Sebb 2010-05-24 19:41:15 UTC
URL: http://svn.apache.org/viewvc?rev=947862&view=rev
Log:
Bug 49333 - SyntheticRepository.loadClass() fails to close the inputStream

Modified:
   jakarta/bcel/trunk/src/main/java/org/apache/bcel/util/SyntheticRepository.java