Bug 49388 - The ScriptSock can't be longer than 7 characters
Summary: The ScriptSock can't be longer than 7 characters
Status: RESOLVED FIXED
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: Core (show other bugs)
Version: 2.2.15
Hardware: PC Linux
: P2 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords: FixedInTrunk
: 49879 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-06-04 12:05 UTC by Samuel Mendenhall
Modified: 2012-02-26 17:05 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Mendenhall 2010-06-04 12:05:45 UTC
If the ScriptSock file name is 7 letter long, e.g.,"cgisock". The PID appent to the file name will be truncated, e.g., cgisock.1234 when the real PID is 12345.
Comment 1 Stefan Fritsch 2010-06-06 15:09:50 UTC
I cannot reproduce this. But under Linux, the total path length for UNIX domain sockets is 108 chars. Do you hit that limit?

Maybe httpd should print a warning or abort in this case.
Comment 2 Tom Helvey 2010-09-03 17:06:24 UTC
*** Bug 49879 has been marked as a duplicate of this bug. ***
Comment 3 Stefan Fritsch 2010-09-04 07:25:59 UTC
Added a warning in r992583
Comment 4 Stefan Fritsch 2012-02-26 17:05:20 UTC
2.4.1 is released, closing