Bug 49415 - workbook.cloneSheet() throws exception (BeginRecord does not implement clone())
Summary: workbook.cloneSheet() throws exception (BeginRecord does not implement clone())
Status: RESOLVED DUPLICATE of bug 49096
Alias: None
Product: POI
Classification: Unclassified
Component: HSSF (show other bugs)
Version: 3.6-FINAL
Hardware: PC Windows XP
: P2 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-09 10:58 UTC by Torsten
Modified: 2010-06-09 14:12 UTC (History)
0 users



Attachments
xml file containing a chart. produces the described error. (38.00 KB, application/vnd.ms-excel)
2010-06-09 10:58 UTC, Torsten
Details
[PATCH] (16.40 KB, patch)
2010-06-09 11:05 UTC, Torsten
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Torsten 2010-06-09 10:58:12 UTC
Created attachment 25567 [details]
xml file containing a chart. produces the described error.

cloneSheet() throws an exception when calling it on a worksheet containing a chart (see example)
Reason is, that many chart records do not overwrite clone so the base class (Record) throws this exception.
Comment 1 Torsten 2010-06-09 11:05:00 UTC
Created attachment 25568 [details]
[PATCH]


the attached ZIP contains the HSSF chart record classes including the missing clone() methods.
Comment 2 Nick Burch 2010-06-09 14:12:43 UTC
This was fixed in svn a little while ago - please test with a recent nightly / svn checkout, and re-open the bug if you discover another part of your problem remains

*** This bug has been marked as a duplicate of bug 49096 ***