Bug 49522 - Complete Server status (status/all) causes stack trace
Complete Server status (status/all) causes stack trace
Status: RESOLVED FIXED
Product: Tomcat 7
Classification: Unclassified
Component: Manager
7.0.0
PC Windows XP
: P2 normal (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2010-06-29 10:41 UTC by Sebb
Modified: 2010-07-01 14:07 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebb 2010-06-29 10:41:51 UTC
type Exception report

message

description The server encountered an internal error () that prevented it from fulfilling this request.

exception

javax.servlet.ServletException: javax.management.AttributeNotFoundException:  Cannot find attribute startTime for org.apache.catalina.deploy.NamingResources@d1c778
	org.apache.catalina.manager.StatusManagerServlet.doGet(StatusManagerServlet.java:292)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:621)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:722)

root cause

javax.management.AttributeNotFoundException:  Cannot find attribute startTime for org.apache.catalina.deploy.NamingResources@d1c778
	org.apache.tomcat.util.modeler.ManagedBean.getGetter(ManagedBean.java:493)
	org.apache.tomcat.util.modeler.BaseModelMBean.getAttribute(BaseModelMBean.java:180)
	com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.getAttribute(DefaultMBeanServerInterceptor.java:666)
	com.sun.jmx.mbeanserver.JmxMBeanServer.getAttribute(JmxMBeanServer.java:638)
	org.apache.catalina.manager.StatusTransformer.writeContext(StatusTransformer.java:656)
	org.apache.catalina.manager.StatusTransformer.writeDetailedState(StatusTransformer.java:590)
	org.apache.catalina.manager.StatusManagerServlet.doGet(StatusManagerServlet.java:287)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:621)
	javax.servlet.http.HttpServlet.service(HttpServlet.java:722)
Comment 1 Mark Thomas 2010-07-01 14:07:25 UTC
Thanks for the report. Fixed in trunk and will be included in 7.0.1 onwards.