Bug 49536 - If no webapps deployed, accessing a URL returns 200 OK with no content instead of 404
If no webapps deployed, accessing a URL returns 200 OK with no content instea...
Status: RESOLVED FIXED
Product: Tomcat 7
Classification: Unclassified
Component: Catalina
unspecified
PC Mac OS X 10.5
: P2 regression (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
: 49566 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2010-07-01 04:07 UTC by S. Ali Tokmen
Modified: 2010-07-07 05:26 UTC (History)
1 user (show)



Attachments
Attachment of the log displayed on console when I access a page, I see a NullPointerException (859 bytes, text/plain)
2010-07-01 04:08 UTC, S. Ali Tokmen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description S. Ali Tokmen 2010-07-01 04:07:11 UTC
Hello

I've just downloaded http://mirror.veriportal.com/apache/tomcat/tomcat-7/v7.0.0-beta/bin/apache-tomcat-7.0.0.zip

If I start a Tomcat 7 instance with no webapps on it and access a URL, it returns HTTP code 200 OK with no content, instead of an HTTP error 404.

Cheers

S. Ali Tokmen
http://ali.tokmen.com/
Comment 1 S. Ali Tokmen 2010-07-01 04:08:00 UTC
Created attachment 25676 [details]
Attachment of the log displayed on console when I access a page, I see a NullPointerException
Comment 2 Mark Thomas 2010-07-01 17:36:02 UTC
Thanks for the report. This is fixed in trunk and will be included in 7.0.1 onwards.
Comment 3 S. Ali Tokmen 2010-07-01 18:54:53 UTC
This is very good news. Thank you very much.
Comment 4 Mark Thomas 2010-07-07 05:26:08 UTC
*** Bug 49566 has been marked as a duplicate of this bug. ***