Bug 49556 - the proc.create function used args as env to get the element count,
Summary: the proc.create function used args as env to get the element count,
Status: RESOLVED DUPLICATE of bug 49557
Alias: None
Product: Tomcat Native
Classification: Unclassified
Component: Library (show other bugs)
Version: 1.1.19
Hardware: PC Windows XP
: P2 critical (vote)
Target Milestone: ---
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-05 21:57 UTC by lanyuflying
Modified: 2011-01-06 21:22 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lanyuflying 2010-07-05 21:57:18 UTC
if (env)
        es = (*e)->GetArrayLength(e, args);

this would cause nullpoint exception like this:

java.lang.NullPointerException
        at org.apache.tomcat.jni.Proc.create(Native Method)
        at hyer.process.Controller.main(Controller.java:91)
Comment 1 jfclere 2011-01-06 11:48:10 UTC
What are you trying to do?
Comment 2 Konstantin Kolinko 2011-01-06 21:22:50 UTC
I mentioned it in
https://issues.apache.org/bugzilla/show_bug.cgi?id=49557#c2

Let's use bug 49557 to track the issues in proc.create

*** This bug has been marked as a duplicate of bug 49557 ***