Bug 49603 - Allow accepting expired certificates on Mail Reader Sampler
Allow accepting expired certificates on Mail Reader Sampler
Status: RESOLVED FIXED
Product: JMeter
Classification: Unclassified
Component: Main
Nightly (Please specify date)
PC Linux
: P2 enhancement (vote)
: ---
Assigned To: JMeter issues mailing list
:
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2010-07-16 09:29 UTC by Luciana Moreira
Modified: 2010-08-16 18:20 UTC (History)
2 users (show)



Attachments
Adds security settings to Mail Reader Sampler (49.26 KB, text/plain)
2010-07-20 09:52 UTC, Luciana Moreira
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luciana Moreira 2010-07-16 09:29:09 UTC
Behaviour observed on SVN Revision: 964795
It would be convenient to allow the Mail Reader Sampler to accept expired certificates, specially since JMeter is supposed to be used on test environments.

Right now I cannot say if SMTP Sampler is also affected by this.

In addition, it would also be interesting to add the functionality available on SMTP Sampler to manage the truststore:
* trust all certificates
* use local keystore
Comment 1 Luciana Moreira 2010-07-16 09:29:56 UTC
Changing it to enhancement priority
Comment 2 Luciana Moreira 2010-07-20 09:52:00 UTC
Created attachment 25787 [details]
Adds security settings to Mail Reader Sampler

I have created the code necessary to add the same Security Settings JPanel of SMTP Sampler in Mail Reader Sampler.

I am not fully sure of what happened, but since we integrated the SMTP Sampler the Mail Reader Sampler is not able anymore to connect to our test server (this worked before). Maybe the geronimo mail library allowed the connection with any server...

In any case this looks to me like a regression, so I will modify its priority.
Comment 3 Sebb 2010-07-20 14:10:23 UTC
(In reply to comment #2)
>
> I am not fully sure of what happened, but since we integrated the SMTP Sampler
> the Mail Reader Sampler is not able anymore to connect to our test server (this
> worked before). Maybe the geronimo mail library allowed the connection with any
> server...
> 
> In any case this looks to me like a regression, so I will modify its priority.

Please open a separate Bugzilla for this.
Comment 4 Luciana Moreira 2010-07-21 03:29:59 UTC
Bug with regression report created, see bug 49626
Comment 5 Sebb 2010-08-16 18:20:14 UTC
Thanks for the patch, which has been applied with a few changes.
[E.g. the values for USE_SSL etc. were reverted to their original settings to maintain compatibility with existing JMX files]

URL: http://svn.apache.org/viewvc?rev=986140&view=rev
Log:
Bug 49603 - Allow accepting expired certificates on Mail Reader Sampler

Added:
   jakarta/jmeter/trunk/src/protocol/mail/org/apache/jmeter/protocol/smtp/sampler/gui/SecuritySettingsPanel.java   (with props)
Modified:
   jakarta/jmeter/trunk/docs/images/screenshots/mailreader_sampler.png
   jakarta/jmeter/trunk/docs/images/screenshots/smtp_sampler.png
   jakarta/jmeter/trunk/src/protocol/mail/org/apache/jmeter/protocol/mail/sampler/MailReaderSampler.java
   jakarta/jmeter/trunk/src/protocol/mail/org/apache/jmeter/protocol/mail/sampler/gui/MailReaderSamplerGui.java
   jakarta/jmeter/trunk/src/protocol/mail/org/apache/jmeter/protocol/smtp/sampler/SmtpSampler.java
   jakarta/jmeter/trunk/src/protocol/mail/org/apache/jmeter/protocol/smtp/sampler/gui/SmtpPanel.java
   jakarta/jmeter/trunk/src/protocol/mail/org/apache/jmeter/protocol/smtp/sampler/gui/SmtpSamplerGui.java
   jakarta/jmeter/trunk/xdocs/changes.xml
   jakarta/jmeter/trunk/xdocs/images/screenshots/mailreader_sampler.png
   jakarta/jmeter/trunk/xdocs/images/screenshots/smtp_sampler.png
   jakarta/jmeter/trunk/xdocs/usermanual/component_reference.xml