Bug 50505 - 505 HTTP Version Not Supported
Summary: 505 HTTP Version Not Supported
Status: RESOLVED DUPLICATE of bug 50072
Alias: None
Product: Tomcat 6
Classification: Unclassified
Component: Connectors (show other bugs)
Version: 6.0.29
Hardware: Other Linux
: P2 normal (vote)
Target Milestone: default
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-21 04:57 UTC by Kim Yong Hwan
Modified: 2011-01-04 18:05 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kim Yong Hwan 2010-12-21 04:57:31 UTC
My Service used CometProcessor, using tomcat 6.0.29 server.
505 HTTP Version Not Supported error happened.
So, I changed to tomcat 6.0.20 server instead of 6.0.29. There is no error. 

I did not change any configuration and just changed tomcat server.

in server.xml

    <Connector acceptorThreadCount="4" socket.tcpNoDelay="true" connectionTimeout="20000"
     port="10129" maxThreads="512" backlog="1000" protocol="org.apache.coyote.http11.Http11NioProtocol"
     useComet="true" redirectPort="8443" />


I saw the HTTP11NioProtocol source(java\org\apache\coyote\http11\Http11NioProtocol.java) and found difference of Http11NioProtocol.java between tomcat 6.0.20 and 6.0.29. 

in Http11NioProtocol.java

public SocketState process(NioChannel socket) {
..
 if (processor.comet) {
                        NioEndpoint.KeyAttachment att = (NioEndpoint.KeyAttachment)socket.getAttachment(false);
                        socket.getPoller().add(socket,att.getCometOps());
                    } else {
                    	release(socket);  <== 6.0.29 added 
                        socket.getPoller().add(socket);
                    }
..
}

is it possible to 505 error when releasing socket???
Comment 1 Mark Thomas 2011-01-04 18:05:36 UTC

*** This bug has been marked as a duplicate of bug 50072 ***