Bug 50638 - Creating XSSFWorkbook works on windows but not on Linux
Summary: Creating XSSFWorkbook works on windows but not on Linux
Status: RESOLVED INVALID
Alias: None
Product: POI
Classification: Unclassified
Component: XSSF (show other bugs)
Version: 3.7-FINAL
Hardware: PC Linux
: P2 major (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-22 20:50 UTC by Popescu
Modified: 2011-01-22 21:27 UTC (History)
0 users



Attachments
the programm that works on windows but fails on linux (623 bytes, text/plain)
2011-01-22 20:50 UTC, Popescu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Popescu 2011-01-22 20:50:04 UTC
Created attachment 26537 [details]
the programm that works on windows but fails on linux

Creating XSSFWorkbook generates an exception (see below). The same programm works fine on windows. The programm is atached.

Exception in thread "main" java.lang.NoClassDefFoundError: org.openxmlformats.schemas.spreadsheetml.x2006.main.impl.CTWorkbookImpl
   at java.lang.Class.initializeClass(libgcj.so.11)
   at java.lang.reflect.Constructor.newInstance(libgcj.so.11)
   at org.apache.xmlbeans.impl.schema.SchemaTypeImpl.createUnattachedNode(SchemaTypeImpl.java:1859)
   at org.apache.xmlbeans.impl.schema.SchemaTypeImpl.createTypeStoreUser(SchemaTypeImpl.java:1805)
   at org.apache.xmlbeans.impl.store.Xobj.setStableType(Xobj.java:1390)
   at org.apache.xmlbeans.impl.store.Cur.setType(Cur.java:2497)
   at org.apache.xmlbeans.impl.store.Cur.setType(Cur.java:2482)
   at org.apache.xmlbeans.impl.store.Locale.newInstance(Locale.java:630)
   at org.apache.xmlbeans.impl.store.Locale.newInstance(Locale.java:606)
   at org.apache.xmlbeans.impl.schema.SchemaTypeLoaderBase.newInstance(SchemaTypeLoaderBase.java:198)
   at org.openxmlformats.schemas.spreadsheetml.x2006.main.CTWorkbook$Factory.newInstance(Unknown Source)
   at org.apache.poi.xssf.usermodel.XSSFWorkbook.onWorkbookCreate(XSSFWorkbook.java:256)
   at org.apache.poi.xssf.usermodel.XSSFWorkbook.<init>(XSSFWorkbook.java:169)
   at ex1.main(ex1.java:11)
Caused by: java.lang.ClassNotFoundException: org.openxmlformats.schemas.spreadsheetml.x2006.main.CTFileVersion not found in gnu.gcj.runtime.SystemClassLoader{urls=[file:./poi-3.7-20101029.jar,file:./poi-ooxml-3.7-20101029.jar,file:./poi-ooxml-schemas-3.7-20101029.jar,file:ooxml-lib/xmlbeans-2.3.0.jar,file:ooxml-lib/dom4j-1.6.1.jar,file:./], parent=gnu.gcj.runtime.ExtensionClassLoader{urls=[], parent=null}}
   at java.net.URLClassLoader.findClass(libgcj.so.11)
   at gnu.gcj.runtime.SystemClassLoader.findClass(libgcj.so.11)
   at java.lang.ClassLoader.loadClass(libgcj.so.11)
   at java.lang.ClassLoader.loadClass(libgcj.so.11)
   at java.lang.Class.initializeClass(libgcj.so.11)
   ...13 more
Comment 1 David Fisher 2011-01-22 21:27:02 UTC
Please see http://poi.apache.org/faq.html#faq-N10025