Bug 50813 - Apache 2.2 and official VC9 builds
Summary: Apache 2.2 and official VC9 builds
Status: RESOLVED INVALID
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: Build (show other bugs)
Version: 2.2.17
Hardware: PC All
: P2 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-21 03:12 UTC by Maxime THEPAULT
Modified: 2011-02-21 03:43 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maxime THEPAULT 2011-02-21 03:12:15 UTC
Hi,

It's not a real bug, but a feature request...

For the moment, Apache 2.2 provides Windows VC6 builds.

But, with VC9, it's faster, and PHP group provides more VC9 builds.

They tell we must don't use their VC9 builds with your VC6 builds, because of possible problems.

I know unofficial VC9 builds exists :
http://www.apachelounge.com/download/

Maybe you will create VC9 builds in the future ?

Thank you ;)
Comment 1 William A. Rowe Jr. 2011-02-21 03:36:04 UTC
Won't happen.  First, ASF HTTP Server project creates no binaries ... a few are created by committers for a few arbitrary, random and capricious platforms, and users have no influence on those chosen.

But more specifically 2.2 is in maintenance and won't change.  For 2.4, from MS the Studio 2010 toolchain is current, so that's the end of that discussion, supporting dated compilers from the outset is simply stupid.  There was a logic to preserving the use of msvcrt.dll for a significant period of time, but VC9 has no such redeeming qualities.
Comment 2 Maxime THEPAULT 2011-02-21 03:43:47 UTC
So, to use PHP VC9 builds, the only way is to use unofficial builds ?

Thank you ;)