Bug 50864 - Reconfigure pool on the fly using JMX
Reconfigure pool on the fly using JMX
Status: RESOLVED FIXED
Product: Tomcat Modules
Classification: Unclassified
Component: jdbc-pool
unspecified
PC All
: P2 normal (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
: 53346 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2011-03-03 11:15 UTC by Filip Hanik
Modified: 2012-06-13 15:52 UTC (History)
2 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Filip Hanik 2011-03-03 11:15:31 UTC
Provide a way to reconfigure the jdbc-pool using JMX and have it take effect when changes are submitted.
http://markmail.org/message/x6wem3zkxl4ps7ki
Comment 1 guenther 2012-02-13 16:06:58 UTC
To note in this context is also the fact that currently (Tomcat JDBC Connection Pool 1.1.0.0) several setter-methods in org.apache.tomcat.jdbc.pool.jmx.ConnectionPools
have an empty body.

As long as they are not implemented it is better to remove them (the settermethods, not the getter-methods) from the mbean interface, otherwise the user believes to can change these values, but in truth the changes are not considered at all.
Comment 2 Raja 2012-04-02 23:14:34 UTC
We also ran into this issue recently. For example, it would be very useful to increase max size of the pool without restarting the server.

Is there a traction on this? Would it help if we submit a patch?
Comment 3 Filip Hanik 2012-04-05 17:57:15 UTC
you got it, changes are underway
Comment 4 Filip Hanik 2012-04-10 16:34:19 UTC
Trunk fix in r1311844
7.0.x fix in r1311848
Will in be Tomcat 7.0.28 and onwards
Comment 5 Filip Hanik 2012-06-13 15:52:32 UTC
*** Bug 53346 has been marked as a duplicate of this bug. ***