Bug 50914 - "DirectoryIndex index" fail to work with +MultiViews options
Summary: "DirectoryIndex index" fail to work with +MultiViews options
Status: RESOLVED DUPLICATE of bug 45225
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: mod_negotiation (show other bugs)
Version: 2.2.9
Hardware: PC Linux
: P2 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on: 45225
Blocks:
  Show dependency tree
 
Reported: 2011-03-11 01:02 UTC by Zhang Weiwu
Modified: 2013-04-30 21:41 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zhang Weiwu 2011-03-11 01:02:37 UTC
Debian 5.0, apache 2 2.2.9-10. I've optioned multiviews, and it
works perfectly fine for every document except index page.

All site using URIs without file extension names, every URI map to 2
files. e.g. about_us have 2 corresponding files:

about_us.en.html
about_us.de.html

And accessing /about_us gets the right language according to browser
setting, works perfectly.

Problem being the index page shows up as a blank page. More tests shows:

                       Firefox       w3m          wget
http://mysite          blank page    blank page   English page
http://mysite/index    English page  English page English page

Expected behavior is http://mysite should not show non-blank page in any case, if I understood the document right.


Here is related section of configuration

	<Directory /var/www/www.realss.com.cn/htdocs/>
		Options FollowSymLinks MultiViews +Includes
		DirectoryIndex index
		AllowOverride All
		Order allow,deny
		allow from all
		AddHandler server-parsed .shtml
		SSITimeFormat "%S"
		XBitHack on
		Header append Vary cookie 
	</Directory>

To workaround this issue, I have to replace "DirectoryIndex index" with:

    DirectoryIndex index.en.html


This breaks multviews on the index page of course. Removing execution bit of the index.??.html files would not workaround this issue.
Comment 1 Zhang Weiwu 2011-03-11 01:12:21 UTC
I cannot believe I reported the same problem twice. This is a duplicate of my original report Bug 45225. Please people who have permission close this bug as duplicate.
Comment 2 Zhang Weiwu 2011-03-11 01:13:20 UTC

*** This bug has been marked as a duplicate of bug 45225 ***