Bug 51310 - Connector destroyInternal Execution
Connector destroyInternal Execution
Status: RESOLVED FIXED
Product: Tomcat 7
Classification: Unclassified
Component: Connectors
7.0.12
PC All
: P2 normal (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
: 51638 (view as bug list)
Depends on:
Blocks:
  Show dependency tree
 
Reported: 2011-06-01 15:58 UTC by Gurkan Erdogdu
Modified: 2011-08-09 20:12 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gurkan Erdogdu 2011-06-01 15:58:45 UTC
In Tomcat 7.0.12 Connector#destroyInternal method has never been called while server is under shutdown. Therefore NIOBlockingSelector#close is never called. Is it bug or else?
Comment 1 Mark Thomas 2011-06-02 13:26:52 UTC
It actually doesn't matter since the JVM is shutting down. However, the right thing to do is to call Server.destroy() after calling Server.stop() so I have made the necessary change to 7.0.x and it will be included in 7.0.15 onwards.
Comment 2 Mark Thomas 2011-08-09 20:12:26 UTC
*** Bug 51638 has been marked as a duplicate of this bug. ***