Bug 51454 - Office 2003 Excel warning
Summary: Office 2003 Excel warning
Status: RESOLVED WONTFIX
Alias: None
Product: POI
Classification: Unclassified
Component: HSSF (show other bugs)
Version: 3.6-FINAL
Hardware: PC Windows XP
: P2 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-30 15:36 UTC by D. Farto
Modified: 2020-01-13 11:44 UTC (History)
0 users



Attachments
excel generation source (29.91 KB, application/octet-stream)
2011-06-30 16:47 UTC, D. Farto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description D. Farto 2011-06-30 15:36:28 UTC
After generating an .xls file using POI 3.6, when i try to open it i get an error message that says something like "Errors have been detected in the file but it could be opened doing the following repairs:
One or more invalid names have been removed" 

I dont know the exact words in english because my excel is in spanish.

After prompting me with this warning it lets me view the file correctly. If I save the file i dont get this warning again.

If opened with later versions of Microsoft Office it wont show the warning, and if saved with these later versions and then opened with Microsoft Excel 2003 it wont show it either.

Excuse me if my english is a bit poor.

Thanks in advance.
Comment 1 Yegor Kozlov 2011-06-30 15:49:44 UTC
Try the latest build from trunk. Daily builds can be downloaded from here:
 http://encore.torchbox.com/poi-cvs-build/ 

If the problem is still there, please post full sample code to reproduce it.

Yegor
Comment 2 D. Farto 2011-06-30 16:47:00 UTC
Created attachment 27232 [details]
excel generation source
Comment 3 D. Farto 2011-06-30 16:47:54 UTC
We tried to use the latest version and it didnt work.

I have attached the source we use to generate this files.

Thanks,

Diego.
Comment 4 Dominik Stadler 2017-06-16 13:25:40 UTC
It has been a long time since anybody did take a look at this issue, is this still a problem for you with the latest version of Apache POI?
Comment 5 Dominik Stadler 2017-10-10 11:31:16 UTC
Very long time without progress here, there were many changes which likely fixed this problem already. Also the attached test-case is very elaborate, making it very hard to reproduce the problem.

If this is still a problem for you, then please reopen the issue with a test-case that is reduced to the bare minimum while still showing the problem.