Bug 51476 - [PATCH] Fixes broken cell formatting for boolean values; fixes html conversion for XSSF
Summary: [PATCH] Fixes broken cell formatting for boolean values; fixes html conversio...
Status: RESOLVED FIXED
Alias: None
Product: POI
Classification: Unclassified
Component: XSSF (show other bugs)
Version: 3.8-dev
Hardware: PC All
: P2 regression (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-05 15:29 UTC by Fabio Corubolo
Modified: 2011-07-08 14:28 UTC (History)
0 users



Attachments
patch in tar.gz as created by ant (591 bytes, application/x-gzip)
2011-07-05 15:29 UTC, Fabio Corubolo
Details
PATCH file in txt from ant script, the tar.gz one was empty for some reason (1.85 KB, patch)
2011-07-05 15:33 UTC, Fabio Corubolo
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Fabio Corubolo 2011-07-05 15:29:06 UTC
Created attachment 27258 [details]
patch in tar.gz as created by ant

This patch fixes two regressions that break cell formatting and html conversion, that seem due to API changes:
1) In the SS formatter:
the cell formatter was broken when evaluating boolean cell values.
2) in the HTML conversion:
a 4 byte rgba vector was expected; this has changed, the patch address the issue.

This can be tested by running org.apache.poi.ss.examples.html.ToHtml on the test file FormulaEvalTestData.xls
Comment 1 Fabio Corubolo 2011-07-05 15:33:59 UTC
Created attachment 27259 [details]
PATCH file in txt from ant script, the tar.gz one was empty for some reason

previous patch was empty sorry
Comment 2 Nick Burch 2011-07-08 14:28:10 UTC
Thanks, applied in r1144331.