Bug 51574 - HSSFWorkbook is final
Summary: HSSFWorkbook is final
Status: RESOLVED DUPLICATE of bug 45919
Alias: None
Product: POI
Classification: Unclassified
Component: HSSF (show other bugs)
Version: 3.7-FINAL
Hardware: PC Linux
: P2 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-07-28 11:52 UTC by Chris B
Modified: 2011-07-28 13:03 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris B 2011-07-28 11:52:08 UTC
Since POI 3.7 the class HSSFWorkbook is declared final, while it was not in 3.6. Also XSSFWorkbook is not declared final.

I need to extend the class which now no longer is possible. Is there any reason the class was made final? Or can this be reverted?
Comment 1 Chris B 2011-07-28 11:54:11 UTC
Just verified that this behaviour is the same in 3.8-beta3
Comment 2 Yegor Kozlov 2011-07-28 13:03:55 UTC
A similar request was requested in the past:

https://issues.apache.org/bugzilla/show_bug.cgi?id=45919

Use composition instead of inheritance, this is the recommended approach to extend POI.

Yegor

*** This bug has been marked as a duplicate of bug 45919 ***