Bug 51652 - Saxon JAR in the application's WEB-INF/lib will cause javax.xml.parsers.ParserConfigurationException: AElfred parser is namespace-aware
Summary: Saxon JAR in the application's WEB-INF/lib will cause javax.xml.parsers.Parse...
Status: RESOLVED DUPLICATE of bug 51395
Alias: None
Product: Tomcat 7
Classification: Unclassified
Component: Catalina (show other bugs)
Version: 7.0.16
Hardware: PC All
: P4 normal (vote)
Target Milestone: ---
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-12 03:28 UTC by Vlad
Modified: 2011-08-12 09:14 UTC (History)
0 users



Attachments
Extraction from log with error trace (14.14 KB, application/octet-stream)
2011-08-12 03:28 UTC, Vlad
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vlad 2011-08-12 03:28:07 UTC
Created attachment 27377 [details]
Extraction from log with error trace

I have an application which includes saxon6.5.5.jar into its WEB-INF/lib directory which seems to be causing the exception specified as soon as I start the Tomcat.

The OS is Win7x64, Tomcat only has default webapps and no additional configuration.

That looks like a similar issue to https://issues.apache.org/bugzilla/show_bug.cgi?id=29936.

Please note that I can't just upgrade the saxon library as this is an old application for which we still providing the support.

Strangely enough running the exact same app on the Tomcat 5.5.15 (although WinXPx32) seems to be working without problems.

The trace from the log is attached.
Comment 1 Mark Thomas 2011-08-12 09:14:55 UTC

*** This bug has been marked as a duplicate of bug 51395 ***