Bug 51785 - XSSFSheet.setForceFormulaRecalculation fails with Class Not Found
Summary: XSSFSheet.setForceFormulaRecalculation fails with Class Not Found
Status: RESOLVED FIXED
Alias: None
Product: POI
Classification: Unclassified
Component: XSSF (show other bugs)
Version: 3.8-dev
Hardware: All All
: P2 minor (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
: 51929 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-09-08 07:13 UTC by Antti Koskimäki
Modified: 2011-10-04 12:24 UTC (History)
1 user (show)



Attachments
new testcase for XSSFSheet (1.02 KB, application/octet-stream)
2011-09-08 07:13 UTC, Antti Koskimäki
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Antti Koskimäki 2011-09-08 07:13:23 UTC
Created attachment 27472 [details]
new testcase for XSSFSheet

poi-ooxml-schemas.jar doesn't contain org.openxmlformats.schemas.spreadsheetml.x2006.main.CTSheetCalcPr needed for setForceFormulaRecalculation

Attached patch to XSSFSheet test-cases, yielding to compile-ooxml-lite rule to add needed classes to poi-ooxml-schemas.jar
Comment 1 Nick Burch 2011-09-09 15:11:42 UTC
Thanks for this, patch applied (with a few small tweaks) in r1167241.
Comment 2 Yegor Kozlov 2011-10-04 12:24:31 UTC
*** Bug 51929 has been marked as a duplicate of this bug. ***