Bug 51929 - POI 3.8-beta4 XSSFSheet.setForceFormulaRecalculation()
Summary: POI 3.8-beta4 XSSFSheet.setForceFormulaRecalculation()
Status: RESOLVED DUPLICATE of bug 51785
Alias: None
Product: POI
Classification: Unclassified
Component: XSSF (show other bugs)
Version: 3.8-dev
Hardware: PC Windows XP
: P2 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-30 13:58 UTC by Yousef
Modified: 2011-10-04 12:24 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousef 2011-09-30 13:58:07 UTC
When used the method setForceFormulaRecalculation() on a XSSFSheet, the following error is thrown:

java.lang.NoClassDefFoundError: org/openxmlformats/schemas/spreadsheetml/x2006/main/CTSheetCalcPr
	at org.openxmlformats.schemas.spreadsheetml.x2006.main.impl.CTWorksheetImpl.addNewSheetCalcPr(Unknown Source)
	at org.apache.poi.xssf.usermodel.XSSFSheet.setForceFormulaRecalculation(XSSFSheet.java:1557)

I look in to "poi-ooxml-schemas-3.8-beta4....jar" and the class is missing.
Comment 1 Nick Burch 2011-09-30 14:17:21 UTC
Short term, just switch to the full schemas file (ooxml-schemas-1.1)

Longer term, any chance you could write a short unit test that uses the recalculation flag? We use the unit tests to decide which bits of the schema to copy over
Comment 2 Yegor Kozlov 2011-10-04 12:24:31 UTC
This seems to be fixed in https://issues.apache.org/bugzilla/show_bug.cgi?id=51785

Please try with the
latest build from trunk. Daily builds can be downloaded from here:
http://encore.torchbox.com/poi-cvs-build/

*** This bug has been marked as a duplicate of bug 51785 ***