Bug 51941 - Formula evaluations fail when refering to multiple sheet in sum
Summary: Formula evaluations fail when refering to multiple sheet in sum
Status: RESOLVED DUPLICATE of bug 48703
Alias: None
Product: POI
Classification: Unclassified
Component: XSSF (show other bugs)
Version: 3.7-FINAL
Hardware: PC All
: P2 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-03 17:17 UTC by mikkel
Modified: 2011-10-03 18:42 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mikkel 2011-10-03 17:17:48 UTC
XSSFFormulaEvaluator.evaluateAllFormulaCells(workBook) fails if the workbook contains a formula of the following type:
=SUM(David:Anders!AL9)

or

SUM('David A:Anders p'!AL9)



This type of formulas are described as the second tip in the following link:
http://office.microsoft.com/en-us/excel-help/5-tips-for-working-with-multiple-worksheets-in-excel-HA001042919.aspx




The text is also inserted here:



Sum the value of a cell across multiple worksheets
 
Another common Excel task is to sum the value of a cell in multiple worksheets and then display the result in another cell. For example, you may want to sum the number of a particular product that customers have ordered over a period of time, such as by quarterly periods. If worksheets are formatted in the same way for each period, the total sales for the product always appears in the same cell in each worksheet.
 
Finding the sum in this situation is simple. You can use a formula:
 1.Start Excel. A new, blank workbook appears.
2.In cell B3 in Sheet1, type 20.
3.In cell B3 in both Sheet2 and Sheet3, type 30.
4.In cell A1 in Sheet1, type the following formula:
=SUM(Sheet1:Sheet3!B3)
5.Press ENTER. Notice that cell A1 displays 80, which is the total sum of the cells in the three worksheets.
Comment 1 Nick Burch 2011-10-03 17:30:10 UTC
Is this a duplicate of https://issues.apache.org/bugzilla/show_bug.cgi?id=48703 ?
Comment 2 mikkel 2011-10-03 17:56:40 UTC
Yes it looks like it is a dublicate and I have just tested 3.9 beta4 and the bug is also in there.
Can I do more to help?

The error is fairly easy to replicate
Comment 3 Nick Burch 2011-10-03 18:42:09 UTC
Resolving as a duplicate of bug #48703. See that bug for the details of what's currently needed

*** This bug has been marked as a duplicate of bug 48703 ***