Bug 51986 - CSV Data Set Config only parses headers when CSV file is comma separated
Summary: CSV Data Set Config only parses headers when CSV file is comma separated
Status: RESOLVED DUPLICATE of bug 51988
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.5
Hardware: PC All
: P2 minor (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-07 03:33 UTC by Andre Versluis
Modified: 2011-10-07 18:57 UTC (History)
1 user (show)



Attachments
This works, all commas (17.95 KB, text/plain)
2011-10-07 11:31 UTC, Andre Versluis
Details
All comma's (59 bytes, text/plain)
2011-10-07 11:33 UTC, Andre Versluis
Details
This uses tabs in header and data. This results in an error (17.95 KB, text/plain)
2011-10-07 11:34 UTC, Andre Versluis
Details
All tabs (59 bytes, text/plain)
2011-10-07 11:34 UTC, Andre Versluis
Details
Same test plan as nr 2, but trying to mix comma and tab (17.95 KB, text/plain)
2011-10-07 11:36 UTC, Andre Versluis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andre Versluis 2011-10-07 03:33:55 UTC
This works: Parameter names configured in CSV Data Set Config, separator in CSV file = a comma
This works: Parameter names configured in CSV Data Set Config, separator in CSV file = a tab
This works: Parameter names not configured in CSV Data Set Config, separator in CSV file = a comma, header line states parameters
This does not work: Parameter names not configured in CSV Data Set Config, separator in CSV file = a tab, header line states parameters

I also vaguely remember having reported an issue where after a first iteration through the CSV file, the header line was taken as a parameter line. I also believe that at that time the above issue did not exist.

Don't know under which user name I reported this, it was some time ago (2 yrs?) and I changed companies since.
Comment 1 Philippe Mouawad 2011-10-07 07:01:38 UTC
Hello,
Can you attach a simple test plan and your csv file ?

Thank you
Regards
Philippe
Comment 2 Andre Versluis 2011-10-07 11:31:40 UTC
Created attachment 27721 [details]
This works, all commas

Uses login.txt
Comment 3 Andre Versluis 2011-10-07 11:33:00 UTC
Created attachment 27722 [details]
All comma's
Comment 4 Andre Versluis 2011-10-07 11:34:15 UTC
Created attachment 27723 [details]
This uses tabs in header and data. This results in an error

jmeter error
2011/10/07 12:56:28 INFO  - jmeter.threads.JMeterThread: Thread finished: Thread Group 1-3 
2011/10/07 12:56:28 INFO  - jmeter.engine.StandardJMeterEngine: Ending thread Thread Group 1-3 
2011/10/07 12:56:28 INFO  - jmeter.engine.StandardJMeterEngine: Notifying test listeners of end of test 
2011/10/07 12:56:28 INFO  - jmeter.gui.util.JMeterMenuBar: setRunning(false,*local*) 
2011/10/07 12:56:28 INFO  - jmeter.engine.StandardJMeterEngine: Test has ended 
2011/10/07 12:56:31 ERROR - jmeter.JMeter: Uncaught exception:  java.lang.NullPointerException
	at org.apache.jmeter.protocol.http.proxy.ProxyControl.findApplicableElements(ProxyControl.java:706)
	at org.apache.jmeter.protocol.http.proxy.ProxyControl.deliverSampler(ProxyControl.java:397)
	at org.apache.jmeter.protocol.http.proxy.Proxy.run(Proxy.java:296)
Comment 5 Andre Versluis 2011-10-07 11:34:43 UTC
Created attachment 27724 [details]
All tabs
Comment 6 Andre Versluis 2011-10-07 11:36:50 UTC
Created attachment 27725 [details]
Same test plan as nr 2, but trying to mix comma and tab

This results in a running test plan but with just ${user} and ${password} filled in, instead of actual data
Comment 7 Andre Versluis 2011-10-07 11:39:37 UTC
And last but not least, this test plan also runs properly, just as the first, when you fill in "user,password" in the parameter field, "\t" in the delimiter field and no header in the tab delimited CSV file.
Comment 8 Philippe Mouawad 2011-10-07 18:39:53 UTC
(In reply to comment #4)
> Created attachment 27723 [details]
> This uses tabs in header and data. This results in an error
> 
> jmeter error
> 2011/10/07 12:56:28 INFO  - jmeter.threads.JMeterThread: Thread finished:
> Thread Group 1-3 
> 2011/10/07 12:56:28 INFO  - jmeter.engine.StandardJMeterEngine: Ending thread
> Thread Group 1-3 
> 2011/10/07 12:56:28 INFO  - jmeter.engine.StandardJMeterEngine: Notifying test
> listeners of end of test 
> 2011/10/07 12:56:28 INFO  - jmeter.gui.util.JMeterMenuBar:
> setRunning(false,*local*) 
> 2011/10/07 12:56:28 INFO  - jmeter.engine.StandardJMeterEngine: Test has ended 
> 2011/10/07 12:56:31 ERROR - jmeter.JMeter: Uncaught exception: 
> java.lang.NullPointerException
>     at
> org.apache.jmeter.protocol.http.proxy.ProxyControl.findApplicableElements(ProxyControl.java:706)
>     at
> org.apache.jmeter.protocol.http.proxy.ProxyControl.deliverSampler(ProxyControl.java:397)
>     at org.apache.jmeter.protocol.http.proxy.Proxy.run(Proxy.java:296)

In this one you say you use \t as delimiter , but in test plan you declared ,
So it is OK for me if it fails.
Comment 9 Philippe Mouawad 2011-10-07 18:57:47 UTC
(In reply to comment #0)
> This works: Parameter names configured in CSV Data Set Config, separator in CSV
> file = a comma
> This works: Parameter names configured in CSV Data Set Config, separator in CSV
> file = a tab
> This works: Parameter names not configured in CSV Data Set Config, separator in
> CSV file = a comma, header line states parameters
> This does not work: Parameter names not configured in CSV Data Set Config,
> separator in CSV file = a tab, header line states parameters
> 

This has been reported as 51988. It is fixed in trunk.
Please test with nightly build when it is available.

> I also vaguely remember having reported an issue where after a first iteration
> through the CSV file, the header line was taken as a parameter line. I also
> believe that at that time the above issue did not exist.
> 
> Don't know under which user name I reported this, it was some time ago (2 yrs?)
> and I changed companies since.

*** This bug has been marked as a duplicate of bug 51988 ***