Bug 51997 - Calling Stop when running a Test with JMS Subscriber leaves connection to JMS servers open
Summary: Calling Stop when running a Test with JMS Subscriber leaves connection to JMS...
Status: RESOLVED INVALID
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.5.1
Hardware: All All
: P2 normal (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
: 52034 (view as bug list)
Depends on:
Blocks: 52044
  Show dependency tree
 
Reported: 2011-10-08 15:18 UTC by Philippe Mouawad
Modified: 2011-10-31 04:39 UTC (History)
2 users (show)



Attachments
Test Plan (7.53 KB, application/octet-stream)
2011-10-08 15:18 UTC, Philippe Mouawad
Details
JMeter log file (107.96 KB, application/octet-stream)
2011-10-08 15:19 UTC, Philippe Mouawad
Details
Thread Dump (8.43 KB, text/plain)
2011-10-08 15:20 UTC, Philippe Mouawad
Details
Test Plan using OpenJMS (6.04 KB, application/xml)
2011-10-08 20:18 UTC, Philippe Mouawad
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Mouawad 2011-10-08 15:18:30 UTC
Created attachment 27736 [details]
Test Plan

Hello,
Scenario:
- Using ActiveMQ 5.5.0
- Start test 
- Let one sample run
- Call stop before it ends

We have Thread ActiveMQ Tranport tcp://.... Running.


I think it's a bug in ActiveMQ but I open an issue here if anyone meets the same issue.
Cause is due to an exception occuring on close:
2011/10/08 17:16:59 ERROR - jmeter.protocol.jms.client.ReceiveSubscriber: Error during close:  javax.jms.JMSException: java.io.InterruptedIOException
	at org.apache.activemq.util.JMSExceptionSupport.create(JMSExceptionSupport.java:62)
	at org.apache.activemq.ActiveMQConnection.doSyncSendPacket(ActiveMQConnection.java:1342)
	at org.apache.activemq.ActiveMQConnection.close(ActiveMQConnection.java:660)
	at org.apache.jmeter.protocol.jms.Utils.close(Utils.java:65)
	at org.apache.jmeter.protocol.jms.client.ReceiveSubscriber.close(ReceiveSubscriber.java:236)
	at org.apache.jmeter.protocol.jms.sampler.SubscriberSampler.threadFinished(SubscriberSampler.java:305)
	at org.apache.jmeter.threads.JMeterThread$ThreadListenerTraverser.addNode(JMeterThread.java:579)
	at org.apache.jorphan.collections.HashTree.traverseInto(HashTree.java:986)
	at org.apache.jorphan.collections.HashTree.traverse(HashTree.java:969)
	at org.apache.jmeter.threads.JMeterThread.threadFinished(JMeterThread.java:554)
	at org.apache.jmeter.threads.JMeterThread.run(JMeterThread.java:328)
	at java.lang.Thread.run(Thread.java:680)
Caused by: java.io.InterruptedIOException
	at org.apache.activemq.transport.WireFormatNegotiator.oneway(WireFormatNegotiator.java:102)
	at org.apache.activemq.transport.MutexTransport.oneway(MutexTransport.java:40)
	at org.apache.activemq.transport.ResponseCorrelator.asyncRequest(ResponseCorrelator.java:81)
	at org.apache.activemq.transport.ResponseCorrelator.request(ResponseCorrelator.java:91)
	at org.apache.activemq.ActiveMQConnection.doSyncSendPacket(ActiveMQConnection.java:1329)
	... 10 more
Comment 1 Philippe Mouawad 2011-10-08 15:19:11 UTC
Created attachment 27737 [details]
JMeter log file
Comment 2 Philippe Mouawad 2011-10-08 15:20:37 UTC
Created attachment 27738 [details]
Thread Dump
Comment 3 Philippe Mouawad 2011-10-08 15:46:08 UTC
(In reply to comment #0)
> Created attachment 27736 [details]
> Test Plan
> 
> Hello,
> Scenario:
> - Using ActiveMQ 5.5.0
> - Start test 
> - Let one sample run
> - Call stop before it ends
> 
> We have Thread ActiveMQ Tranport tcp://.... Running.
> 
> 
> I think it's a bug in ActiveMQ but I open an issue here if anyone meets the
> same issue.
> Cause is due to an exception occuring on close:
> 2011/10/08 17:16:59 ERROR - jmeter.protocol.jms.client.ReceiveSubscriber: Error
> during close:  javax.jms.JMSException: java.io.InterruptedIOException
>     at
> org.apache.activemq.util.JMSExceptionSupport.create(JMSExceptionSupport.java:62)
>     at
> org.apache.activemq.ActiveMQConnection.doSyncSendPacket(ActiveMQConnection.java:1342)
>     at
> org.apache.activemq.ActiveMQConnection.close(ActiveMQConnection.java:660)
>     at org.apache.jmeter.protocol.jms.Utils.close(Utils.java:65)
>     at
> org.apache.jmeter.protocol.jms.client.ReceiveSubscriber.close(ReceiveSubscriber.java:236)
>     at
> org.apache.jmeter.protocol.jms.sampler.SubscriberSampler.threadFinished(SubscriberSampler.java:305)
>     at
> org.apache.jmeter.threads.JMeterThread$ThreadListenerTraverser.addNode(JMeterThread.java:579)
>     at org.apache.jorphan.collections.HashTree.traverseInto(HashTree.java:986)
>     at org.apache.jorphan.collections.HashTree.traverse(HashTree.java:969)
>     at
> org.apache.jmeter.threads.JMeterThread.threadFinished(JMeterThread.java:554)
>     at org.apache.jmeter.threads.JMeterThread.run(JMeterThread.java:328)
>     at java.lang.Thread.run(Thread.java:680)
> Caused by: java.io.InterruptedIOException
>     at
> org.apache.activemq.transport.WireFormatNegotiator.oneway(WireFormatNegotiator.java:102)
>     at
> org.apache.activemq.transport.MutexTransport.oneway(MutexTransport.java:40)
>     at
> org.apache.activemq.transport.ResponseCorrelator.asyncRequest(ResponseCorrelator.java:81)
>     at
> org.apache.activemq.transport.ResponseCorrelator.request(ResponseCorrelator.java:91)
>     at
> org.apache.activemq.ActiveMQConnection.doSyncSendPacket(ActiveMQConnection.java:1329)
>     ... 10 more


It seems issue is due to the call of t.interrupt(); in StandardJMeterEngine#tellThreadsToStop.

ActiveMQ does not like it.
Comment 4 Philippe Mouawad 2011-10-08 16:04:23 UTC
Issue opened at ActiveMQ:
https://issues.apache.org/jira/browse/AMQ-3529
Comment 5 Philippe Mouawad 2011-10-08 20:18:56 UTC
Created attachment 27742 [details]
Test Plan using OpenJMS

Issue seems to be in ActiveMQ as we don't have it with OpenJMS.
TO run test add following libraries to jmeter lib folder: 
-spice-jndikit-1.2.jar
-openjms-tunnel-0.7.7-beta-1.war
-openjms-tools-0.7.7-beta-1.jar
-openjms-net-0.7.7-beta-1.jar
-openjms-common-0.7.7-beta-1.jar
-openjms-0.7.7-beta-1.jar
Comment 6 Philippe Mouawad 2011-10-15 14:32:33 UTC
It also breaks Subscriber in AMQ.
Comment 7 Philippe Mouawad 2011-10-17 18:49:01 UTC
*** Bug 52034 has been marked as a duplicate of this bug. ***
Comment 8 Yaroslav 2011-10-18 18:18:18 UTC
*** Bug 52034 has been marked as a duplicate of this bug. ***
Comment 9 Philippe Mouawad 2011-10-29 22:15:50 UTC
Bug fixed in activemq 5.6.0

Waiting for release for test.
Comment 10 Philippe Mouawad 2011-10-30 10:28:07 UTC
Tested with nightly build.
Bug still there.

Provided JUnit Test case to reproduce issue.
Comment 11 Philippe Mouawad 2011-10-31 04:39:20 UTC
Issue fixed in upcomint ActiveMQ 5.6.0 version.

Issue was not a JMeter one, closing as invalid.