Bug 52276 - tomcat deploy will be blocked without LockOutRealm
Summary: tomcat deploy will be blocked without LockOutRealm
Status: RESOLVED DUPLICATE of bug 52259
Alias: None
Product: Tomcat 7
Classification: Unclassified
Component: Catalina (show other bugs)
Version: 7.0.23
Hardware: PC All
: P2 blocker (vote)
Target Milestone: ---
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-02 05:20 UTC by quaff
Modified: 2011-12-02 08:58 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description quaff 2011-12-02 05:20:03 UTC
If I comment <Realm className="org.apache.catalina.realm.LockOutRealm">..</Realm> under <Engine name="Catalina" defaultHost="localhost"> ,tomcat deploy will be blocked when start,7.0.22 works fine without LockOutRealm


2011-12-2 13:11:20 org.apache.coyote.AbstractProtocol init
INFO: Initializing ProtocolHandler ["http-bio-8080"]
2011-12-2 13:11:20 org.apache.coyote.AbstractProtocol init
INFO: Initializing ProtocolHandler ["ajp-bio-8009"]
2011-12-2 13:11:20 org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 866 ms
2011-12-2 13:11:20 org.apache.catalina.core.StandardService startInternal
INFO: Starting service Catalina
2011-12-2 13:11:20 org.apache.catalina.core.StandardEngine startInternal
INFO: Starting Servlet Engine: Apache Tomcat/7.0.23
2011-12-2 13:11:20 org.apache.catalina.startup.HostConfig deployDescriptor
INFO: Deploying configuration descriptor D:\apache-tomcat-7.0.23\conf\Catalina\localhost\ROOT.xml

blocking ...
Comment 1 Rainer Jung 2011-12-02 08:58:02 UTC
Most likely a duplicate of 52259. As a workaround onfiguring any Realm should prevent the deadlock.

This is already fixed and will be released with 7.0.24.

*** This bug has been marked as a duplicate of bug 52259 ***