Bug 52436 - Spaces in ScriptAlias Path kill mod_fcgid
Summary: Spaces in ScriptAlias Path kill mod_fcgid
Status: RESOLVED DUPLICATE of bug 51194
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: mod_fcgid (show other bugs)
Version: 2.2.21
Hardware: All All
: P2 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-06 12:56 UTC by david.graf
Modified: 2012-10-29 20:07 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description david.graf 2012-01-06 12:56:47 UTC
Hello

In my project, we are using the mod_fcgid to handle certain http requests by our own language engine. This used to work perfectly till we upgraded from mod_fcgid 2.3.5 to mod_fcgid 2.3.6. Since then, our fcgid process is not started anymore if the ScriptAlias directive in httpd.conf contains a space. Instead, I see the following in the error log of apache:

326 [Fri Jan 06 11:30:01 2012] [notice] Apache/2.2.21 (Unix) mod_fcgid/2.3.6 configured -- resuming normal operations
327 [Fri Jan 06 11:30:03 2012] [warn] [client 77.58.246.206] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server
328 [Fri Jan 06 11:30:03 2012] [error] [client 77.58.246.206] Premature end of script headers: somename.fcgi

It's only the space in ScriptAlias that causes the trouble. Nothing else. And after we downgraded back to mod_fcgid 2.3.5, it works like a charm.

Best
David
Comment 1 david.graf 2012-01-06 12:58:05 UTC
Forgot to write that I tested it on Ubuntu 10.04 and on Ubuntu 11.10.
Comment 2 Florian Winter 2012-02-29 12:51:59 UTC
This is also broken on Windows. See bug#52795
Comment 3 William A. Rowe Jr. 2012-02-29 18:22:59 UTC
Platform agnostic per comment #2
Comment 4 William A. Rowe Jr. 2012-10-29 20:07:23 UTC
This was the same underlying bug as 51194 - see that ticket for a patch.

*** This bug has been marked as a duplicate of bug 51194 ***