Bug 52502 - Align shortcuts with other programs
Summary: Align shortcuts with other programs
Status: RESOLVED WONTFIX
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.5.1
Hardware: All Windows XP
: P2 enhancement with 1 vote (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-23 15:47 UTC by immanuel.hayden
Modified: 2012-05-18 21:15 UTC (History)
2 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description immanuel.hayden 2012-01-23 15:47:28 UTC
Hi!

I would love to see JMeter aligning it's shortcuts with other programs.
I am especially thinking about:
* Ctrl+F does not search which is confusing for everyone
* Help is typically F1, in SoapUI it is Ctrl+H (which would be great for the function helper)
* Ctrl+W ("What's this node?" - does that actually do something? It didn't respond to any selected node when I tried it just now...) typically closes the active file or window which is what Ctrl+L does now.

Hope this does not just sound like a rant ;)
Imm
Comment 1 Sebb 2012-01-23 16:27:07 UTC
(In reply to comment #0)
> Hi!
> 
> I would love to see JMeter aligning it's shortcuts with other programs.

JMeter is cross-platform. 
Are the following shortcuts common to Windows, Mac and Unix?

> I am especially thinking about:
> * Ctrl+F does not search which is confusing for everyone
> * Help is typically F1, in SoapUI it is Ctrl+H (which would be great for the
> function helper)

AFAIK, the F1 key is not available on all systems/OSes.

JMeter uses Ctrl+H throughout for Help (not just SOAPUI).

> * Ctrl+W ("What's this node?" - does that actually do something? 

Check the console window.

> It didn't
> respond to any selected node when I tried it just now...) typically closes the
> active file or window which is what Ctrl+L does now.
Comment 2 immanuel.hayden 2012-01-23 18:02:04 UTC
> JMeter is cross-platform. 
> Are the following shortcuts common to Windows, Mac and Unix?
Basic stuff like Ctrl+F is common in all Desktop Environments to my knowledge (Mac OS X, Gnome, KDE, Windows).
> JMeter uses Ctrl+H throughout for Help (not just SOAPUI).
Eh, sorry, I meant JMeter of course, some sidetask I had to do in SoapUI at the time of writing this must have distracted me ;) SoapUI uses the standard F1 for accessing the help.
Comment 3 Philippe Mouawad 2012-01-25 22:55:03 UTC
Hello,
I agree with immanuel on:
CTRL+F or CMD + F (Apple) => Which usually opens a search dialog
F1 for help seems also reasonable for me , in JMeter case we would have to decide if it opens Function Helper Dialog or Help 
CTRL + ? could be used for help
CRTL +W is used by What's this node, which in my opinion is rarely used by users (I use it as JMeter developer) and we should replace it by Close
CTRL+N could be added for a new file

Regards
Philippe
Comment 4 immanuel.hayden 2012-01-26 07:30:39 UTC
> F1 for help seems also reasonable for me , in JMeter case we would have to
> decide if it opens Function Helper Dialog or Help 
my thought was that F1 could open the normal help
> CRTL +W is used by What's this node, which in my opinion is rarely used by
> users (I use it as JMeter developer) and we should replace it by Close
You could call the functionality "Node info", because then Ctrl+I would be a natural binding choice and you don't lose a (maybe useful) shortcut :D
> CTRL+N could be added for a new file
fully agree :)
Comment 5 Sebb 2012-01-26 11:17:14 UTC
If we do make any changes, key sequences need to be valid on all major OSes.

Also, I think the changes need to be optional, as shortcuts tend to become automatic  - this is why it's a problem when they differ between systems and applications.

In particular with the Ctrl+W shortcut, the proposed new setting is drastically different, but other changes too can confuse existing users.

Perhaps someone should start a Wiki page with the current and proposed settings; easier to see the whole picture than an sequence of issue or e-mail posts.

The best might be to allow users to configure the shortcuts somehow.
Comment 6 Philippe Mouawad 2012-01-29 17:40:41 UTC
WIki page written:
http://wiki.apache.org/jmeter/JMeterShortcuts
Comment 7 Philippe Mouawad 2012-02-04 11:29:35 UTC
*** Bug 52601 has been marked as a duplicate of this bug. ***
Comment 8 Philippe Mouawad 2012-02-04 11:30:47 UTC
+1 for ctrl+f opening search popup as per duplicate bug
Comment 9 Philippe Mouawad 2012-03-18 14:58:05 UTC
Hello,
What shall we do with this ?

A request for opinions on user mailing list might help ?

Regards
Philippe
Comment 10 shmulikk 2012-03-18 16:46:49 UTC
I think there is no need to discuss this as this is so trivial.
If you feel like it's worth asking the community, I won't object ;)
Comment 11 Philippe Mouawad 2012-03-20 20:41:37 UTC
Hello M. Krakower ,
Can you clarify your point ?:
Do you mean it's useless or useful ?

Thanks
Regards
Comment 12 shmulikk 2012-03-20 21:15:31 UTC
Hi,
I think changing the default value of expand tree to false is good enough.
I think there is no need to open this to community discussion, according to the reponses already made, but if you want to open this to discussion, do it.

I hope that's clearer.
Comment 13 Philippe Mouawad 2012-03-20 21:19:43 UTC
Are you sure you are answering the right bug  ?
Maybe confusing with 52934 ?
Comment 14 shmulikk 2012-03-20 21:34:06 UTC
Right ;)
Regarding CTRL+F it might be worth asking the community.
I think that currently no one is really using the current CTRL+F to get to the Functions Helper, but maybe it's only me.

So now it's hopefuly a response in place.
Comment 15 Philippe Mouawad 2012-04-30 21:57:53 UTC
Hello Sebb, Milamber, Rainer,
What do you think of this one ? abandon it or implement wiki proposal ?

Thanks
Regards
Philippe
Comment 16 Philippe Mouawad 2012-05-18 21:15:29 UTC
Closing as we could not have consensus on this.