Bug 52594 - rpmbuild -ba errors out with "File not found by glob"
Summary: rpmbuild -ba errors out with "File not found by glob"
Status: RESOLVED LATER
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: Build (show other bugs)
Version: 2.2.22
Hardware: PC Linux
: P2 normal (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL:
Keywords: MassUpdate
Depends on:
Blocks:
 
Reported: 2012-02-03 18:07 UTC by NWoodward
Modified: 2018-11-07 21:09 UTC (History)
2 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description NWoodward 2012-02-03 18:07:59 UTC
This is actually for version 2.2.22, which wasn't available in the drop-down list. When packaging apache with rpmbuild -ba, I get these errors:

Processing files: httpd-2.2.22-1
error: File not found by glob: /home/NWoodward/rpmbuild/tmp/httpd-2.2.22-1-root/usr/share/man/man8/ab*
error: File not found by glob: /home/NWoodward/rpmbuild/tmp/httpd-2.2.22-1-root/usr/share/man/man8/logresolve*
Executing(%doc): /bin/sh -e /home/NWoodward/rpmbuild/tmp/rpm-tmp.68180
+ umask 022
+ cd /home/NWoodward/rpmbuild/BUILD
+ cd httpd-2.2.22
+ DOCDIR=/home/NWoodward/rpmbuild/tmp/httpd-2.2.22-1-root/usr/share/doc/httpd-2.2.22
+ export DOCDIR
+ rm -rf /home/NWoodward/rpmbuild/tmp/httpd-2.2.22-1-root/usr/share/doc/httpd-2.2.22
+ /bin/mkdir -p /home/NWoodward/rpmbuild/tmp/httpd-2.2.22-1-root/usr/share/doc/httpd-2.2.22
+ cp -pr ABOUT_APACHE README CHANGES LICENSE NOTICE /home/NWoodward/rpmbuild/tmp/httpd-2.2.22-1-root/usr/share/doc/httpd-2.2.22
+ exit 0
Processing files: httpd-devel-2.2.22-1
error: File not found by glob: /home/NWoodward/rpmbuild/tmp/httpd-2.2.22-1-root/usr/share/man/man8/apxs.8*
Processing files: httpd-manual-2.2.22-1
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Obsoletes: secureweb-manual apache-manual
Processing files: mod_ssl-2.2.22-1
Provides: config(mod_ssl) = 2.2.22-1 mod_ssl.so()(64bit)
Requires(interp): /bin/sh
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Requires(post): /bin/sh
Requires: config(mod_ssl) = 2.2.22-1 httpd httpd-mmn = 20051115 libc.so.6()(64bit) libc.so.6(GLIBC_2.2.5)(64bit) libcrypto.so.6()(64bit) libdistcache.so.1()(64bit) libdl.so.2()(64bit) libnal.so.1()(64bit) libpthread.so.0()(64bit) libssl.so.6()(64bit) libz.so.1()(64bit) make rtld(GNU_HASH)
Processing files: httpd-debuginfo-2.2.22-1
Provides: ab.debug()(64bit) checkgid.debug()(64bit) htcacheclean.debug()(64bit) htdbm.debug()(64bit) htdigest.debug()(64bit) htpasswd.debug()(64bit) httpd.debug()(64bit) httpd.event.debug()(64bit) httpd.worker.debug()(64bit) httxt2dbm.debug()(64bit) logresolve.debug()(64bit) mod_actions.so.debug()(64bit) mod_alias.so.debug()(64bit) mod_asis.so.debug()(64bit) mod_auth_basic.so.debug()(64bit) mod_auth_digest.so.debug()(64bit) mod_authn_alias.so.debug()(64bit) mod_authn_anon.so.debug()(64bit) mod_authn_dbd.so.debug()(64bit) mod_authn_dbm.so.debug()(64bit) mod_authn_default.so.debug()(64bit) mod_authn_file.so.debug()(64bit) mod_authnz_ldap.so.debug()(64bit) mod_authz_dbm.so.debug()(64bit) mod_authz_default.so.debug()(64bit) mod_authz_groupfile.so.debug()(64bit) mod_authz_host.so.debug()(64bit) mod_authz_owner.so.debug()(64bit) mod_authz_user.so.debug()(64bit) mod_autoindex.so.debug()(64bit) mod_cache.so.debug()(64bit) mod_cern_meta.so.debug()(64bit) mod_cgi.so.debug()(64bit) mod_cgid.so.debug()(64bit) mod_dav.so.debug()(64bit) mod_dav_fs.so.debug()(64bit) mod_dbd.so.debug()(64bit) mod_deflate.so.debug()(64bit) mod_dir.so.debug()(64bit) mod_disk_cache.so.debug()(64bit) mod_dumpio.so.debug()(64bit) mod_env.so.debug()(64bit) mod_expires.so.debug()(64bit) mod_ext_filter.so.debug()(64bit) mod_filter.so.debug()(64bit) mod_headers.so.debug()(64bit) mod_ident.so.debug()(64bit) mod_include.so.debug()(64bit) mod_info.so.debug()(64bit) mod_ldap.so.debug()(64bit) mod_log_config.so.debug()(64bit) mod_log_forensic.so.debug()(64bit) mod_logio.so.debug()(64bit) mod_mime.so.debug()(64bit) mod_mime_magic.so.debug()(64bit) mod_negotiation.so.debug()(64bit) mod_proxy.so.debug()(64bit) mod_proxy_ajp.so.debug()(64bit) mod_proxy_balancer.so.debug()(64bit) mod_proxy_connect.so.debug()(64bit) mod_proxy_ftp.so.debug()(64bit) mod_proxy_http.so.debug()(64bit) mod_proxy_scgi.so.debug()(64bit) mod_reqtimeout.so.debug()(64bit) mod_rewrite.so.debug()(64bit) mod_setenvif.so.debug()(64bit) mod_speling.so.debug()(64bit) mod_ssl.so.debug()(64bit) mod_status.so.debug()(64bit) mod_substitute.so.debug()(64bit) mod_suexec.so.debug()(64bit) mod_unique_id.so.debug()(64bit) mod_userdir.so.debug()(64bit) mod_usertrack.so.debug()(64bit) mod_version.so.debug()(64bit) mod_vhost_alias.so.debug()(64bit) rotatelogs.debug()(64bit) suexec.debug()(64bit)
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Checking for unpackaged file(s): /usr/lib/rpm/check-files /home/NWoodward/rpmbuild/tmp/httpd-2.2.22-1-root


RPM build errors:
    File not found by glob: /home/NWoodward/rpmbuild/tmp/httpd-2.2.22-1-root/usr/share/man/man8/ab*
    File not found by glob: /home/NWoodward/rpmbuild/tmp/httpd-2.2.22-1-root/usr/share/man/man8/logresolve*
    File not found by glob: /home/NWoodward/rpmbuild/tmp/httpd-2.2.22-1-root/usr/share/man/man8/apxs.8*


Commenting out the offending lines from the %files section of the spec file allows the build to succeed, but I'm not sure if this is the ideal solution.

Steps to Reproduce:

1) Download the stable 2.2.22 tarball from http://httpd.apache.org/download.cgi
2) Extract the httpd.spec file and place it in SPECS within your build dir, place the tarball in SOURCES within your build dir
3) rpmbuild -ba httpd.spec

Expected results: httpd get built and packaged successfully. Actual results: rpmbuild errors out with the output above.

Built on 2012-02-03 using version 2.2.22 on CentOS 5.7.
Comment 1 Rainer Jung 2012-02-10 07:51:51 UTC
The man pages for ab, apxs and logresolve have been moved from man section 8 to 1 in r1221296 in order to reflect a changed installation directory (moved from sbin to bin).

This seems to be an unintended side-effect of work for trunk, because trunk and 2.2 use the same build scripts for documentation including man pages.

Need to check, whether we want to fix the specs file or move the man pages back for 2.2.x.
Comment 2 Adams Biyi 2012-03-25 16:28:41 UTC
Work Around:

I recently encountered similar build errors:



RPM build errors:
    File not found by glob: /var/tmp/httpd-2.2.22-1-root/usr/share/man/man8/ab*
    File not found by glob: /var/tmp/httpd-2.2.22-1-root/usr/share/man/man8/logresolve*
    File not found by glob: /var/tmp/httpd-2.2.22-1-root/usr/share/man/man8/apxs.8*

My work-around was to edit the httpd.spec file and comment out the rules for these man pages.  After that, I reran the build successfully

$> rpmbuild --clean httpd.spec
$> rpmbuild -ba --sign httpd.spec

Hope this helps until the apache team finds and tell us the real problem and solution
Comment 3 William A. Rowe Jr. 2018-11-07 21:09:55 UTC
Please help us to refine our list of open and current defects; this is a mass update of old and inactive Bugzilla reports which reflect user error, already resolved defects, and still-existing defects in httpd.

As repeatedly announced, the Apache HTTP Server Project has discontinued all development and patch review of the 2.2.x series of releases. The final release 2.2.34 was published in July 2017, and no further evaluation of bug reports or security risks will be considered or published for 2.2.x releases. All reports older than 2.4.x have been updated to status RESOLVED/LATER; no further action is expected unless the report still applies to a current version of httpd.

If your report represented a question or confusion about how to use an httpd feature, an unexpected server behavior, problems building or installing httpd, or working with an external component (a third party module, browser etc.) we ask you to start by bringing your question to the User Support and Discussion mailing list, see [https://httpd.apache.org/lists.html#http-users] for details. Include a link to this Bugzilla report for completeness with your question.

If your report was clearly a defect in httpd or a feature request, we ask that you retest using a modern httpd release (2.4.33 or later) released in the past year. If it can be reproduced, please reopen this bug and change the Version field above to the httpd version you have reconfirmed with.

Your help in identifying defects or enhancements still applicable to the current httpd server software release is greatly appreciated.