Bug 52598 - slide background color not considered in ppt2png export
Summary: slide background color not considered in ppt2png export
Status: RESOLVED FIXED
Alias: None
Product: POI
Classification: Unclassified
Component: HSLF (show other bugs)
Version: 3.8-dev
Hardware: PC Windows XP
: P2 major (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-04 06:26 UTC by Peter B.
Modified: 2012-02-22 12:59 UTC (History)
0 users



Attachments
problematic ppt (9.50 KB, application/vnd.ms-powerpoint)
2012-02-04 06:26 UTC, Peter B.
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter B. 2012-02-04 06:26:49 UTC
Created attachment 28265 [details]
problematic ppt

POI Version: 3.8-beta5

see the attached ppt sample.
Whenever I run sample code: "Export PowerPoint slides into java.awt.Graphics2D" found on: http://poi.apache.org/slideshow/how-to-shapes.html

background color is not considered in export

and as my presentation has black bg and white text in the output I don't see anything at all, just white image
Comment 1 Yegor Kozlov 2012-02-06 07:08:46 UTC
There are known issues with exporting ppt slides to png and the missing background is one of them.  Unfortunately we don't have an active developer working on HSLF and you will have to wait until the problem is fixed. 

Note that a similar functionality is available for the .pptx format (PPTX2PNG). Does background render correctly for .pptx files ?  

Yegor
Comment 2 Peter B. 2012-02-06 07:45:03 UTC
thanks for reply, 
well pptx2png is not my use case currently, someone should probably test and see.
Comment 3 Yegor Kozlov 2012-02-22 12:59:57 UTC
Should be fixed in r1292267

Yegor