Bug 53030 - File Not Found in BFS Sampler. Sampler not referencing any file though.
Summary: File Not Found in BFS Sampler. Sampler not referencing any file though.
Status: RESOLVED DUPLICATE of bug 52728
Alias: None
Product: JMeter
Classification: Unclassified
Component: HTTP (show other bugs)
Version: 2.6
Hardware: All All
: P2 normal (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-03 19:00 UTC by jomebrew
Modified: 2012-04-03 21:48 UTC (History)
2 users (show)



Attachments
Jmeter Log (6.02 KB, application/octet-stream)
2012-04-03 19:00 UTC, jomebrew
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jomebrew 2012-04-03 19:00:52 UTC
Created attachment 28540 [details]
Jmeter Log

File Not Found in BFS Sampler.  Sampler does not referencing any file though.  

Script has been working fine for a couple years with 2.4 and 2.5.1.  tested 2,6 today and am experiencing this now.

- Two thread groups
- Both reference same user csv file (user,pass)
- Each thread logs in the users and executes HTTP procedures
- Second Thread group uses BFS sampler (in while container) to set a couple variables
   - Language is javascript
   - Script is simple
randt = vars.get("randtop");
var randomx=Math.floor(Math.random()*randt);
vars.put("GR",randomx);

- Attaching Log

Jmeter is throwing a 500 error 

Thread Name: Thread Group QDN 1-1
Sample Start: 2012-04-03 18:52:23 GMT
Load time: 2
Latency: 0
Size in bytes: 0
Headers size in bytes: 0
Body size in bytes: 0
Sample Count: 1
Error Count: 1
Response code: 500
Response message: java.io.FileNotFoundException: pcmuser_1_250.csv (The system cannot find the file specified)

Response headers:


SampleResult fields:
ContentType: 
DataEncoding: null



2012/04/03 18:21:49 WARN  - jmeter.protocol.java.sampler.BSFSampler: Problem evaluating the script java.io.FileNotFoundException: pcmuser_1_250.csv (The system cannot find the file specified)
	at java.io.FileInputStream.open(Native Method)
	at java.io.FileInputStream.<init>(Unknown Source)
	at java.io.FileInputStream.<init>(Unknown Source)
	at org.apache.jmeter.protocol.java.sampler.BSFSampler.sample(BSFSampler.java:97)
	at org.apache.jmeter.threads.JMeterThread.process_sampler(JMeterThread.java:416)
	at org.apache.jmeter.threads.JMeterThread.run(JMeterThread.java:271)
	at java.lang.Thread.run(Unknown Source)
Comment 1 Philippe Mouawad 2012-04-03 20:24:57 UTC
Hello,
Can you attach a simple test plan that reproduces the issue ?

Thanks
Regards
Philippe
Comment 2 Philippe Mouawad 2012-04-03 20:28:16 UTC
I think this is currently fixed in nightly build which you can find here:
http://jmeter.apache.org/nightly.html

*** This bug has been marked as a duplicate of bug 52728 ***
Comment 3 jomebrew 2012-04-03 21:25:09 UTC
Replaced the Bin and Lib directories with the last night (4/03) build.   

Still has same problem.
Comment 4 jomebrew 2012-04-03 21:48:34 UTC
(In reply to comment #3)
> Replaced the Bin and Lib directories with the last night (4/03) build.   
> 
> Still has same problem.

Strike that.  I replaced the lib and bin directory again and verified the version.  For some reason, most the files were replaced on the first copy but not all of them.  Windows can be weird.

e:\jmeter-run-2.6\bin>jmeter -v
Copyright (c) 1998-2012 The Apache Software Foundation
Version r1308652

Successfully execute this procedure.

Thanks!