Bug 53262 - XSSFCellStyle.getFillForegroundXSSFColor returs null if theme color is set as Accent color in the Styles panel
Summary: XSSFCellStyle.getFillForegroundXSSFColor returs null if theme color is set as...
Status: RESOLVED DUPLICATE of bug 56295
Alias: None
Product: POI
Classification: Unclassified
Component: XSSF (show other bugs)
Version: 3.8-FINAL
Hardware: PC All
: P2 major with 1 vote (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-18 13:50 UTC by andrei
Modified: 2017-06-20 18:20 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andrei 2012-05-18 13:50:10 UTC
If bg color is set in the Style panel, xml node (in styles.xml) <cellXfs> -> <xf> doesn't have 'applyFill' attribute, and getFillForegroundXSSFColor method checks this parameter. As a result method returns null.
Comment 1 andrei 2012-05-18 14:14:39 UTC
And for the same reason method getFillPattern returns 0.
Comment 2 Yegor Kozlov 2012-12-08 13:15:31 UTC
Andrey,

You will get nothing by raising priority of your bugs in Bugzilla. The status of your tickets  is NEW which means that no one from the POI team found time to work on them.

One thing to remember is that Apache POI is a volunteer project. If these bugs are important to you, please do work on them and submit patches! At minimum, post sample Java code that demonstrates the problem.  Ideally that would be a failing unit test. If the test requires a input .xlsx file then please attach it too. 

Yegor
Comment 3 Dominik Stadler 2015-09-03 19:30:40 UTC
No update in years, no sample code, therefore closing this as WONTFIX for now. If this is still an issue for you with the latest release 3.13-beta1 then please reopen with at least some sample code that shows the problem, preferably as unit test.
Comment 4 Greg Woolsey 2017-06-20 18:20:17 UTC

*** This bug has been marked as a duplicate of bug 56295 ***