Bug 53346 - Support for changing MaxActive via JMX
Summary: Support for changing MaxActive via JMX
Status: RESOLVED DUPLICATE of bug 50864
Alias: None
Product: Tomcat Modules
Classification: Unclassified
Component: jdbc-pool (show other bugs)
Version: unspecified
Hardware: PC All
: P2 normal (vote)
Target Milestone: ---
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on: 53254
Blocks:
  Show dependency tree
 
Reported: 2012-06-01 16:23 UTC by Brooke Hedrick
Modified: 2012-06-13 15:52 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brooke Hedrick 2012-06-01 16:23:37 UTC
+++ This bug was initially created as a clone of Bug #53254 +++

It is a common function of a connection pool to support resizing the connection pool - ex: MaxActive.  The commons-dbcp BasicDataSource is an example of this.  It would be great if this pool supported such an operation as well.

It would be useful if the operation were exposed through JMX too.
Comment 1 Filip Hanik 2012-06-13 15:52:32 UTC

*** This bug has been marked as a duplicate of bug 50864 ***