Bug 53409 - Request class actively restricts sending parameters in the body unless using POST
Summary: Request class actively restricts sending parameters in the body unless using ...
Status: RESOLVED DUPLICATE of bug 48692
Alias: None
Product: Tomcat 6
Classification: Unclassified
Component: Connectors (show other bugs)
Version: 6.0.35
Hardware: PC All
: P2 enhancement with 1 vote (vote)
Target Milestone: default
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-13 15:00 UTC by Stas
Modified: 2012-08-09 16:44 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stas 2012-06-13 15:00:38 UTC
Hi I did view Bug 48692 and Bug 49964 and http://markmail.org/message/opptokzqz7y6z7nk
It's great you've fixed it in 7.x, but the thing is there are users like me that currently have to develop REST services using Tomcat 6.0.x (which is still a supported version) sadly as I see it, marking Bug 49964 duplicate of Bug 48692 made this fix unavailable for us, Tomcat 6 users, because Tomcat.0.35 was released in the beginning of the year and both bugs were last modified in 2010 and still does not have this simple yet so important fix. So for Tomcat 6.0.x this is still a bug(or an enhancement if you wish to be strict although the RFC does not restrict it and Request.java lines 2599-2600 does :) ) and a very annoying one, that forces manual parsing of the request body and\or other workarounds.
Comment 1 Mark Thomas 2012-07-29 21:35:58 UTC
Note that the restriction is as a result of the Servlet specification (SRV 3.1).
Comment 2 Konstantin Kolinko 2012-07-29 22:21:16 UTC
If you want to backport the "parseBodyMethods" Connectors' attribute to Tomcat 6, someone (you?) has to prepare a patch for Tomcat 6 in unified diff format (as documented elsewhere), and attach it here or better to issue 48692 of which this one is a duplicate.

The code to start is in r1041892, though there were minor changes to it later.
http://svn.apache.org/viewvc?view=revision&revision=1041892
Comment 3 Christopher Schultz 2012-08-09 05:10:40 UTC
(In reply to comment #0)
> It's great you've fixed [this] in 7.x, but the thing is there are users like me
> that currently have to develop REST services using Tomcat 6.0.x (which is
> still a supported version) sadly as I see it, marking Bug 49964 duplicate of
> Bug 48692 made this fix unavailable for us, Tomcat 6 users[.]

Actually, it was marked as a DUPLICATE because I logged a bug that Mark had already logged. His was first (and logged against the current trunk at the time) so we went with his. Back-porting wasn't a high priority but it's not like the closing of bug 49964 has any implication that we will refuse to support Tomcat 6. Just ask for a back-port (which you have basically already done).

(In reply to comment #2)
> If you want to backport the "parseBodyMethods" Connectors' attribute ...
> ...[t]he code to start is in r1041892, though there were minor changes to it
> later.

The original patch is quite small and easily adaptable. Stas, this would be a good entry-level patch for you to submit. Care to submit one based upon my original? Feel free to discuss it on the dev list if you have questions (rather than polluting bugzilla comments).
Comment 4 Christopher Schultz 2012-08-09 16:44:24 UTC

*** This bug has been marked as a duplicate of bug 48692 ***
Comment 5 Christopher Schultz 2012-08-09 16:44:46 UTC
Using the original bug to mention request-for-backport.