Bug 53424 - Add better support for pre-compilation of jsps in a jar
Summary: Add better support for pre-compilation of jsps in a jar
Status: RESOLVED DUPLICATE of bug 50234
Alias: None
Product: Tomcat 7
Classification: Unclassified
Component: Jasper (show other bugs)
Version: 7.0.27
Hardware: PC Windows Vista
: P2 enhancement (vote)
Target Milestone: ---
Assignee: Tomcat Developers Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-16 11:41 UTC by Anthony Gerrard
Modified: 2012-06-17 07:33 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anthony Gerrard 2012-06-16 11:41:05 UTC
It would be good if the various features of the jsp pre compilation ant task better supported the new servlet 3.0 pluggability features:

* ability to load jsp config from META-INF/web-fragment.xml
* ability to merge generated config into META-INF/web-fragment.xml
* loose any other WEB-INF assumptions that there are
Comment 1 Konstantin Kolinko 2012-06-17 07:33:03 UTC

*** This bug has been marked as a duplicate of bug 50234 ***