Bug 53535 - Out of memory while performing ContextConfig.webConfig
Out of memory while performing ContextConfig.webConfig
Status: RESOLVED FIXED
Product: Tomcat 7
Classification: Unclassified
Component: Catalina
unspecified
All All
: P2 normal with 1 vote (vote)
: ---
Assigned To: Tomcat Developers Mailing List
:
: 53615 (view as bug list)
Depends on:
Blocks: 53615
  Show dependency tree
 
Reported: 2012-07-11 10:29 UTC by Cedomir Igaly
Modified: 2014-02-17 13:47 UTC (History)
1 user (show)



Attachments
Suggested solution to improve ContextConfig (2.70 KB, application/octet-stream)
2012-07-11 10:29 UTC, Cedomir Igaly
Details
diff -u (1.77 KB, patch)
2012-07-11 21:38 UTC, Cedomir Igaly
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Cedomir Igaly 2012-07-11 10:29:10 UTC
Created attachment 29047 [details]
Suggested solution to improve ContextConfig

JavaClassCacheEntry objects are using too much memory causing eventually (all kinds of) out of memory errors during container startup. There is no need to save whole JavaClass in cache since only superclass name and interface names are needed in later processing.

Suggested solution is attached.
Comment 1 Mark Thomas 2012-07-11 18:20:46 UTC
Looks like a sensible improvement to me. Can you provide the patch in diff -u format to save me unpicking it please.
Comment 2 Cedomir Igaly 2012-07-11 21:38:18 UTC
Created attachment 29051 [details]
diff -u

Here it is!
Comment 3 Sergey Grigoriev 2012-07-28 11:12:43 UTC
*** Bug 53615 has been marked as a duplicate of this bug. ***
Comment 4 Mark Thomas 2012-07-29 21:23:57 UTC
Thanks for the patch. It has been applied to trunk and 7.0.x and will be included in 7.0.30 onwards.