Bug 53743 - JavaSamplers.allSamplers static Set keeps references even after thread has ended
Summary: JavaSamplers.allSamplers static Set keeps references even after thread has ended
Status: RESOLVED DUPLICATE of bug 53782
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: unspecified
Hardware: All All
: P2 normal (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-20 00:06 UTC by Sebb
Modified: 2012-08-29 11:14 UTC (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebb 2012-08-20 00:06:01 UTC
Ran a delayed start test using a temporary version of TestCompiler that does not store entries in the pairing set.

This still failed with OOME.

Turns out that this was caused by JavaSampler which keeps a reference to each sampler in order to be able to invoke teardownTest() at the end of a test when the main sampler is called through testEnded().

I'm not yet sure if this is a bug or a necessary evil; this bug is to record the behaviour.
Comment 1 Philippe Mouawad 2012-08-20 08:53:22 UTC
Date: Mon Aug 20 08:49:59 2012
New Revision: 1374946

URL: http://svn.apache.org/viewvc?rev=1374946&view=rev
Log:
Bug 53743 - JavaSamplers.allSamplers static Set keeps references even after thread has ended
Bugzilla Id: 53743

Modified:
    jmeter/trunk/src/protocol/java/org/apache/jmeter/protocol/java/sampler/JavaSampler.java
    jmeter/trunk/xdocs/changes.xml
Comment 2 Philippe Mouawad 2012-08-21 13:38:22 UTC
Date: Tue Aug 21 13:37:15 2012
New Revision: 1375541

URL: http://svn.apache.org/viewvc?rev=1375541&view=rev
Log:
Rollback as per discussion on dev mailing list :
http://mail-archives.apache.org/mod_mbox/jmeter-dev/201208.mbox/browser

Bugzilla Id: 53743

Modified:
    jmeter/trunk/src/protocol/java/org/apache/jmeter/protocol/java/sampler/JavaSampler.java
    jmeter/trunk/xdocs/changes.xml
Comment 3 Philippe Mouawad 2012-08-21 22:40:13 UTC
http://mail-archives.apache.org/mod_mbox/jmeter-dev/201208.mbox/%3CCAOGo0VZFuiiR-F3xO2THzQgaDukSBwkfmO3FV0AOkf47UkMjeA%40mail.gmail.com%3E(In reply to comment #2)
> Date: Tue Aug 21 13:37:15 2012
> New Revision: 1375541
> 
> URL: http://svn.apache.org/viewvc?rev=1375541&view=rev
> Log:
> Rollback as per discussion on dev mailing list :
> http://mail-archives.apache.org/mod_mbox/jmeter-dev/201208.mbox/browser
http://mail-archives.apache.org/mod_mbox/jmeter-dev/201208.mbox/%3CCAOGo0VZFuiiR-F3xO2THzQgaDukSBwkfmO3FV0AOkf47UkMjeA%40mail.gmail.com%3E
> 
> Bugzilla Id: 53743
> 
> Modified:
>    
> jmeter/trunk/src/protocol/java/org/apache/jmeter/protocol/java/sampler/
> JavaSampler.java
>     jmeter/trunk/xdocs/changes.xml
Comment 4 Sebb 2012-08-29 11:14:53 UTC

*** This bug has been marked as a duplicate of bug 53782 ***