Bug 53764 - Website : Create a new style for website
Summary: Website : Create a new style for website
Status: RESOLVED FIXED
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.7
Hardware: All All
: P2 enhancement (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-22 21:40 UTC by Philippe Mouawad
Modified: 2016-02-27 09:51 UTC (History)
1 user (show)



Attachments
Stylesheet to create a table-less version of the website (21.67 KB, patch)
2015-02-28 18:40 UTC, Felix Schumacher
Details | Diff
Stylesheet to create a table-less version of the website (24.48 KB, patch)
2015-03-01 12:22 UTC, Felix Schumacher
Details | Diff
Stylesheet to create a table-less version of the website (26.00 KB, patch)
2015-03-05 21:20 UTC, Felix Schumacher
Details | Diff
New layout showing wasted top banner space and font (175.92 KB, application/octet-stream)
2015-03-07 11:59 UTC, Sebb
Details
Old layout showing smaller banner ane neater heading font (135.85 KB, application/octet-stream)
2015-03-07 12:00 UTC, Sebb
Details
Style for medium sized displays (3.14 KB, patch)
2015-03-13 21:09 UTC, Felix Schumacher
Details | Diff
Replace index for usermanual by auto generated one (17.70 KB, patch)
2015-03-20 21:46 UTC, Felix Schumacher
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Mouawad 2012-08-22 21:40:13 UTC
It would be cool to have a new style for website.
Something less white :-)
With arrows for next/previous buttons.
In few words make site look more NET 2.0 or more :-) 

I mark this a minor as it's only for "marketing" :-)
Comment 1 Milamber 2012-08-22 21:59:11 UTC
Perhaps (before) a new logo for Apache JMeter. More modern, more dynamic, less old style. :-)

Need a designer.
Comment 2 Philippe Mouawad 2012-08-22 22:07:18 UTC
Why not open a contest on JMeter user mailing list :-) ?
Comment 3 Chaitanya Bhatt 2015-02-15 20:16:35 UTC
I second the idea of starting a logo contest in the community.
Comment 4 Chaitanya Bhatt 2015-02-15 20:19:42 UTC
I was thinking of a website similar to Apache Cordova :

http://cordova.apache.org/

Opinion?
Comment 5 Felix Schumacher 2015-02-28 18:40:07 UTC
Created attachment 32531 [details]
Stylesheet to create a table-less version of the website

The attached patch generates a new version ob the website without tables (almost, since there are tables in the content files). It has (in my opinion) a bit nicer colors and adapts itself when displayed on smalle devices.

To have a look at it, I uploaded a generated version to http://people.apache.org/~fschumacher/jmeter/index.html
Comment 6 Philippe Mouawad 2015-02-28 20:58:35 UTC
Hi Felix,
I find it much better than existing one with a kind of oldy / classical style :-)
Thanks.
What about using it for new release ?
Regards
Comment 7 Felix Schumacher 2015-03-01 12:22:11 UTC
Created attachment 32536 [details]
Stylesheet to create a table-less version of the website

Tables are now stripped of their old stylings and formatted through css. Apache Ads are included. Twitter icon added and Twitter links at the top will break nicer in case of smaller devices.

I don't want to hinder a release with this. And maybe someone can style the tableless site in a completely different way.
Comment 8 Felix Schumacher 2015-03-05 21:20:06 UTC
Created attachment 32546 [details]
Stylesheet to create a table-less version of the website

A bit more colorful and responsive.

Images will now be scaled, if they are bigger then 800 px and a link will always be added to the original image.

A rendered version for the "current" 2.13 docs are again at http://people.apache.org/~fschumacher/jmeter/
Comment 9 Philippe Mouawad 2015-03-05 23:21:03 UTC
Really nice.
I really think we should release it with 2.13.

Regards
Philippe
Comment 10 Felix Schumacher 2015-03-06 21:09:17 UTC
Date: Fri Mar  6 21:04:57 2015
New Revision: 1664720

URL: http://svn.apache.org/r1664720
Log:
Bug 53764: New layout for the website.

Bugzilla Id: 53764

Added:
    jmeter/trunk/xdocs/css/new-style.css
    jmeter/trunk/xdocs/stylesheets/website-style.xsl
Modified:
    jmeter/trunk/build.xml
Comment 11 Sebb 2015-03-07 11:58:18 UTC
The menu changes look OK, and the coloured lines are fine.

However the banner bar is much too high - there's lots of wasted space.

Also the font used for the headings looks very messy - it looks like it has been produced on a typewriter where most of the keys are partially clogged; the letter outlines are unclear.

See attached screen shots.
Comment 12 Sebb 2015-03-07 11:59:33 UTC
Created attachment 32549 [details]
New layout showing wasted top banner space and font
Comment 13 Sebb 2015-03-07 12:00:53 UTC
Created attachment 32550 [details]
Old layout showing smaller banner ane neater heading font
Comment 14 Felix Schumacher 2015-03-07 12:15:53 UTC
(In reply to Sebb from comment #11)
> The menu changes look OK, and the coloured lines are fine.
> 
> However the banner bar is much too high - there's lots of wasted space.
That can be easily adjusted.

> 
> Also the font used for the headings looks very messy - it looks like it has
> been produced on a typewriter where most of the keys are partially clogged;
> the letter outlines are unclear.
That was intended. If you don't like it, I can take a cleaner font. Do you have any preference?

> 
> See attached screen shots.
Comment 15 Sebb 2015-03-07 12:27:05 UTC
(In reply to Felix Schumacher from comment #14)
> (In reply to Sebb from comment #11)
> > The menu changes look OK, and the coloured lines are fine.
> > 
> > However the banner bar is much too high - there's lots of wasted space.
> That can be easily adjusted.

Please do so.

> > 
> > Also the font used for the headings looks very messy - it looks like it has
> > been produced on a typewriter where most of the keys are partially clogged;
> > the letter outlines are unclear.
> That was intended. If you don't like it, I can take a cleaner font. Do you
> have any preference?

What was wrong with the original header font?
I'm not especially attached to it, but it's easier to read than the new one.
 
> > 
> > See attached screen shots.
Comment 16 Felix Schumacher 2015-03-07 12:47:45 UTC
(In reply to Sebb from comment #15)
> (In reply to Felix Schumacher from comment #14)
> > (In reply to Sebb from comment #11)
> > > The menu changes look OK, and the coloured lines are fine.
> > > 
> > > However the banner bar is much too high - there's lots of wasted space.
> > That can be easily adjusted.
> 
> Please do so.
> 
> > > 
> > > Also the font used for the headings looks very messy - it looks like it has
> > > been produced on a typewriter where most of the keys are partially clogged;
> > > the letter outlines are unclear.
> > That was intended. If you don't like it, I can take a cleaner font. Do you
> > have any preference?
> 
> What was wrong with the original header font?
> I'm not especially attached to it, but it's easier to read than the new one.
I found it a bit boring and being the default it could have been different on each browser/os. I will now use a different one.

>  
> > > 
> > > See attached screen shots.
Comment 17 Felix Schumacher 2015-03-07 12:52:01 UTC
(In reply to Felix Schumacher from comment #16)
> (In reply to Sebb from comment #15)
> > (In reply to Felix Schumacher from comment #14)
> > > (In reply to Sebb from comment #11)
> > > > The menu changes look OK, and the coloured lines are fine.
> > > > 
> > > > However the banner bar is much too high - there's lots of wasted space.
> > > That can be easily adjusted.
> > 
> > Please do so.
> > 
> > > > 
> > > > Also the font used for the headings looks very messy - it looks like it has
> > > > been produced on a typewriter where most of the keys are partially clogged;
> > > > the letter outlines are unclear.
> > > That was intended. If you don't like it, I can take a cleaner font. Do you
> > > have any preference?
> > 
> > What was wrong with the original header font?
> > I'm not especially attached to it, but it's easier to read than the new one.
> I found it a bit boring and being the default it could have been different
> on each browser/os. I will now use a different one.
> 
> >  
> > > > 
> > > > See attached screen shots.

I have checked the changes in and updated the site at http://people.apache.org/~fschumacher/jmeter/
Comment 18 Sebb 2015-03-07 16:10:12 UTC
Font looks a bit better, though it looks old-fashioned to me.

The banner is still larger than it needs to be.
Comment 19 Felix Schumacher 2015-03-07 16:31:41 UTC
(In reply to Sebb from comment #18)
> Font looks a bit better, though it looks old-fashioned to me.
I have changed the font once again. But maybe you could suggest one, that suits you.

> 
> The banner is still larger than it needs to be.
I have made it as small as possible considering the apache ad. It is possible, that the ad will be cut off once the ad will use the full size. We will see.
Comment 20 Sebb 2015-03-07 23:56:12 UTC
(In reply to Felix Schumacher from comment #19)
> (In reply to Sebb from comment #18)
> > Font looks a bit better, though it looks old-fashioned to me.
> I have changed the font once again. But maybe you could suggest one, that
> suits you.

Thanks, the font looks fine to me now.

> > 
> > The banner is still larger than it needs to be.
> I have made it as small as possible considering the apache ad. It is
> possible, that the ad will be cut off once the ad will use the full size. 

Huh? Once the ad size is chosen, it won't change of its own accord. The logos are specifically made in certain sizes only so that page designers know how much space to allocate.

> We will see.
Comment 21 Milamber 2015-03-08 08:06:59 UTC
URL: http://svn.apache.org/r1664949
Log:
Add new-style.css in svn control
Bugzilla Id: 53764

Added:
    jmeter/trunk/docs/css/new-style.css   (with props)


URL: http://svn.apache.org/r1664951
Log:
anchor attribut seems mandatory for subsection balise
Bugzilla Id: 53764

Modified:
    jmeter/trunk/xdocs/mail2.xml
Comment 22 Felix Schumacher 2015-03-08 08:57:17 UTC
Date: Sat Mar  7 12:49:56 2015
New Revision: 1664841

URL: http://svn.apache.org/r1664841
Log:
Less space for the header and use another font for the headings.

Modified:
    jmeter/trunk/xdocs/css/new-style.css
    jmeter/trunk/xdocs/stylesheets/website-style.xsl

Date: Sat Mar  7 13:12:04 2015
New Revision: 1664844

URL: http://svn.apache.org/r1664844
Log:
Add alt-texts to images in screenshots and figures

Modified:
    jmeter/trunk/xdocs/stylesheets/website-style.xsl

Date: Sat Mar  7 13:20:02 2015
New Revision: 1664845

URL: http://svn.apache.org/r1664845
Log:
Alt-text for icons in menu

Modified:
    jmeter/trunk/xdocs/stylesheets/website-style.xsl

Date: Sat Mar  7 14:54:46 2015
New Revision: 1664860

URL: http://svn.apache.org/r1664860
Log:
Use figure element instead of a div and change anchors using name to id (where possible)

Modified:
    jmeter/trunk/xdocs/css/new-style.css
    jmeter/trunk/xdocs/stylesheets/website-style.xsl

Date: Sat Mar  7 15:38:41 2015
New Revision: 1664876

URL: http://svn.apache.org/r1664876
Log:
Scrollbars for iframes have to be hidden using old attributes, as it seems

Modified:
    jmeter/trunk/xdocs/stylesheets/website-style.xsl

Date: Sat Mar  7 16:29:11 2015
New Revision: 1664886

URL: http://svn.apache.org/r1664886
Log:
Use yet another font for headers

Modified:
    jmeter/trunk/xdocs/css/new-style.css
    jmeter/trunk/xdocs/stylesheets/website-style.xsl

Date: Sat Mar  7 17:03:03 2015
New Revision: 1664891

URL: http://svn.apache.org/r1664891
Log:
Use subsections instead of a table for mailing lists.

Modified:
    jmeter/trunk/xdocs/mail2.xml

Date: Sat Mar  7 16:24:00 2015
New Revision: 1664885

URL: http://svn.apache.org/r1664885
Log:
Try to make the header as small as possible. It could be that the apache ad will get cut off, if the ad uses the full height

Modified:
    jmeter/trunk/xdocs/css/new-style.css

Date: Sun Mar  8 08:29:36 2015
New Revision: 1664952

URL: http://svn.apache.org/r1664952
Log:
Use smaller ad banner for apache. Correct margins and width for smaller devices.

Bugzilla Id: 53764

Modified:
    jmeter/trunk/xdocs/css/new-style.css
    jmeter/trunk/xdocs/stylesheets/website-style.xsl
Comment 23 Felix Schumacher 2015-03-08 09:01:38 UTC
(In reply to Sebb from comment #20)
> (In reply to Felix Schumacher from comment #19)
> > (In reply to Sebb from comment #18)
> > > Font looks a bit better, though it looks old-fashioned to me.
> > I have changed the font once again. But maybe you could suggest one, that
> > suits you.
> 
> Thanks, the font looks fine to me now.
> 
> > > 
> > > The banner is still larger than it needs to be.
> > I have made it as small as possible considering the apache ad. It is
> > possible, that the ad will be cut off once the ad will use the full size. 
> 
> Huh? Once the ad size is chosen, it won't change of its own accord. The
> logos are specifically made in certain sizes only so that page designers
> know how much space to allocate.

The ad-banner are placed inside an iframe. We can't control the layout (css/styles) from outside and the html in the iframe doesn't set any values for the margin/padding setting. That way the image will get a border, which makes it bigger. Now I had made the height of the outer div smaller than the height of the iframe. It could not be seen as the image had a lot of white space at top and the bottom. If that would have been changed, that part of the image would than have be cropped.

But as we now use the wide bar instead of the square one, our header can be made to use less height.

> 
> > We will see.
Comment 24 Felix Schumacher 2015-03-08 11:20:56 UTC
Date: Sun Mar  8 11:20:00 2015
New Revision: 1664968

URL: http://svn.apache.org/r1664968
Log:
Generate html for localising directory, even if it is not directly linked.

Bugzilla Id: 53764

Modified:
    jmeter/trunk/build.xml
Comment 25 Felix Schumacher 2015-03-13 20:00:46 UTC
Date: Fri Mar 13 19:36:14 2015
New Revision: 1666554

URL: http://svn.apache.org/r1666554
Log:
Correct navigation for iOS. iOS ignores hover class for elements
which have no listener, so we just add one.

Bugzilla Id: 53764

Modified:
    jmeter/trunk/xdocs/stylesheets/website-style.xsl
Comment 26 Felix Schumacher 2015-03-13 21:09:08 UTC
Created attachment 32566 [details]
Style for medium sized displays

This patch will add another pagesize breakpoint. For displays between 600 and 1000 px it will show a top menu directly below the header.

It also changes the links to be colored brown.
Comment 27 Felix Schumacher 2015-03-20 21:39:52 UTC
Date: Fri Mar 20 21:39:25 2015
New Revision: 1668162

URL: http://svn.apache.org/r1668162
Log:
Generate id attributes for subsections, so that they can be used as link destinations.

Bugzilla Id: 53764

Modified:
    jmeter/trunk/xdocs/stylesheets/website-style.xsl
Comment 28 Felix Schumacher 2015-03-20 21:46:15 UTC
Created attachment 32589 [details]
Replace index for usermanual by auto generated one

Instead of manually placing the index entries for the usermanual, this patch will generate them by using a list of the pages of the usermanual-section.
Comment 29 Felix Schumacher 2015-04-19 08:13:12 UTC
Date: Sat Apr 18 20:48:22 2015
New Revision: 1674583

URL: http://svn.apache.org/r1674583
Log:
Define a doctype with html entities in the new xsl-stylesheet and use the entities.
Because of this change, we don't need to remove superfluos & anymore.

Bugzilla Id: 53764

Modified:
    jmeter/trunk/build.xml
    jmeter/trunk/xdocs/stylesheets/website-style.xsl
Comment 30 Felix Schumacher 2015-04-28 19:51:48 UTC
Date: Tue Apr 28 19:50:59 2015
New Revision: 1676601

URL: http://svn.apache.org/r1676601
Log:
Since amp-entities are not removed anymore since r1674583, we have to define the trade-entity
and use it directly.

Bugzilla Id: 53764

Modified:
    jmeter/trunk/xdocs/index.xml
    jmeter/trunk/xdocs/stylesheets/website-style.xsl
Comment 31 Felix Schumacher 2015-04-28 20:42:14 UTC
Date: Tue Apr 28 20:40:37 2015
New Revision: 1676622

URL: http://svn.apache.org/r1676622
Log:
Followup to r1676601. More html entities, that need to be unescaped
since r1674583.

Bugzilla Id: 53764

Modified:
    jmeter/trunk/xdocs/usermanual/component_reference.xml
    jmeter/trunk/xdocs/usermanual/functions.xml
    jmeter/trunk/xdocs/usermanual/listeners.xml
    jmeter/trunk/xdocs/usermanual/test_plan.xml
Comment 32 Felix Schumacher 2015-04-29 19:14:27 UTC
Date: Wed Apr 29 19:13:02 2015
New Revision: 1676822

URL: http://svn.apache.org/r1676822
Log:
Another followup to r1676601. More html entities, that need to be unescaped
since r1674583.

Bugzilla Id: 53764

Modified:
    jmeter/trunk/xdocs/changes_history.xml
Comment 33 Felix Schumacher 2015-05-10 18:37:12 UTC
Date: Sun May 10 18:36:19 2015
New Revision: 1678594

URL: http://svn.apache.org/r1678594
Log:
Use a menu bar on top for middle sized displays (600px to 1000px wide).
Use orange for links instead of the default which is blue in most browsers.

Bugzilla Id: 53764

Modified:
    jmeter/trunk/xdocs/css/new-style.css
Comment 34 Felix Schumacher 2015-05-15 12:36:59 UTC
Date: Fri May 15 12:35:48 2015
New Revision: 1679554

URL: http://svn.apache.org/r1679554
Log:
Use no background for code tags, and change the text to a bold brown one.
That way the code tags will be clear to see, but not disrupt the overall
picture that much.

Bugzilla Id: 53764

Modified:
    jmeter/trunk/xdocs/css/new-style.css
Comment 35 Felix Schumacher 2015-08-31 18:45:37 UTC
Date: Mon Aug 31 18:45:00 2015
New Revision: 1700295

URL: http://svn.apache.org/r1700295
Log:
Change background of pre/source elements to black and the font to orange. It seems to fit nicer into
overall color scheme and look.

Bugzilla Id: 53764