Bug 53768 - Counter increments if is under If controler with condition set to false
Summary: Counter increments if is under If controler with condition set to false
Status: CLOSED DUPLICATE of bug 56160
Alias: None
Product: JMeter
Classification: Unclassified
Component: Main (show other bugs)
Version: 2.7
Hardware: PC Windows XP
: P2 normal (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-23 16:03 UTC by Grzegorz
Modified: 2014-10-11 21:48 UTC (History)
1 user (show)



Attachments
Jmeter script (7.38 KB, application/octet-stream)
2012-08-23 16:03 UTC, Grzegorz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Grzegorz 2012-08-23 16:03:20 UTC
Created attachment 29269 [details]
Jmeter script

version: 2.7 r1342410

Counter increments in situation described below:

var = 0

if (false)
   {
   if (true)
      {
      Counter(var)
      }
   }

after that var has a value set to 1

if we change this to:
var = 0
if (false)
   {
   BeanShell Sampler
   if (true)
      {
      Counter(var)
      }
   }

then it works correctly

I have attached jmeter script showing this bug
Comment 1 Philippe Mouawad 2012-08-23 21:16:05 UTC

*** This bug has been marked as a duplicate of bug 52496 ***
Comment 2 Philippe Mouawad 2014-10-11 21:47:02 UTC

*** This bug has been marked as a duplicate of bug 56811 ***
Comment 3 Philippe Mouawad 2014-10-11 21:48:10 UTC

*** This bug has been marked as a duplicate of bug 56160 ***