Bug 53848 - HTTP embedded URLs - provide negative regex matching
Summary: HTTP embedded URLs - provide negative regex matching
Status: RESOLVED DUPLICATE of bug 63527
Alias: None
Product: JMeter
Classification: Unclassified
Component: HTTP (show other bugs)
Version: unspecified
Hardware: All All
: P2 enhancement (vote)
Target Milestone: ---
Assignee: JMeter issues mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-10 21:56 UTC by Sebb
Modified: 2020-09-06 07:59 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebb 2012-09-10 21:56:00 UTC
The HTTP Sampler (and defaults) allow an RE to be specified that URLs must match.

It can be tricky to negate REs, so it might be useful to add an optional RE field that URLs must not match (as is done for the HTTP Proxy Server).

It might also be worth considering making the fields tables, rather than single entries. However, this would be trickier to implement whilst still retaining upwards compatibility of JMX files.
Comment 1 Felix Schumacher 2020-09-06 07:59:50 UTC
The tabular field did indeed not get implemented, but rather the simpler approach of an additional field.

*** This bug has been marked as a duplicate of bug 63527 ***