Bug 53898 - Broken Win32 MSI download link
Summary: Broken Win32 MSI download link
Status: RESOLVED FIXED
Alias: None
Product: Apache httpd-2
Classification: Unclassified
Component: Win32 MSI Installer (show other bugs)
Version: 2.2.22
Hardware: PC Windows XP
: P2 minor (vote)
Target Milestone: ---
Assignee: Apache HTTPD Bugs Mailing List
URL: http://httpd.apache.org/download.cgi
Keywords: ErrorMessage
: 53880 53933 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-09-19 06:24 UTC by Daniel Lopez
Modified: 2014-04-26 12:41 UTC (History)
3 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Lopez 2012-09-19 06:24:12 UTC
The link is for 2.2.23, but the file that is available is 2.2.22, so the link is pointing to a non-existent file.
Comment 1 Daniel Lopez 2012-09-19 06:28:10 UTC
http://www.apache.org/dist/httpd/binaries/win32/

The directory listing here is how I figured out why the link was broken regardless of mirror.
Comment 2 Christophe JAILLET 2012-09-19 17:39:03 UTC
*** Bug 53880 has been marked as a duplicate of this bug. ***
Comment 3 Christophe JAILLET 2012-09-25 19:50:41 UTC
*** Bug 53933 has been marked as a duplicate of this bug. ***
Comment 4 Christophe JAILLET 2014-04-26 12:41:48 UTC
Links are now against:
   http://www.apache.org/dist/httpd/binaries/      (or mirror)
where the latest available binaries are stored.

These binaries may not be the latest version of apache, but they are the latest that have been built.

So there is no more broken links.



Moreover, you can pick a link from:
   http://httpd.apache.org/docs/current/en/platform/windows.html#down

You can sometimes find here more up-to-date builds.