Bug 53921 - tar task bug when dealing with UTF-8 char isn't solved
Summary: tar task bug when dealing with UTF-8 char isn't solved
Alias: None
Product: Ant
Classification: Unclassified
Component: Core tasks (show other bugs)
Version: nightly
Hardware: Macintosh All
: P2 normal (vote)
Target Milestone: 1.9.0
Assignee: Ant Notifications List
Depends on:
Reported: 2012-09-22 23:55 UTC by Ângelo Andrade Cirino
Modified: 2014-01-01 22:40 UTC (History)
0 users


Note You need to log in before you can comment on or make changes to this bug.
Description Ângelo Andrade Cirino 2012-09-22 23:55:15 UTC
Like reported in https://issues.apache.org/bugzilla/show_bug.cgi?id=36851 I have had issues with the tar task not being able to use filenames with UTF-8 characters. Consulting the source code I could see that there is an implementation of the longfile="posix" option I committed, built and installed version 1.9.0alpha  and was given the following error:

/Users/aacirino/Documents/ws/vtta1.0/build.xml:60: Problem creating TAR: request to write '110' bytes exceeds size in header of '0' bytes for entry './PaxHeaders.X/vtta.woa/Contents/Frameworks/JavaXML.framework/WebServerResources/Java/com/ibm/wsdl/'

when trying to build the install files for my application under Eclipse.

It is also worth mentioning that the current tar task manual states that there is a posix option for version 1.8.4, what isn't true:


To circumvent this issue I changed my build file to use zip instead of tar, but tar is preferable due to the ability of setting file permissions in the build file.
Comment 1 Stefan Bodewig 2014-01-01 22:40:03 UTC
what you see is Ant's version of https://issues.apache.org/jira/browse/COMPRESS-203 whose fix was merged into Ant in December 2012 - so it should work with 1.9.0's final release.

BTW, you can specify file permissions for zip as well.