Bug 53926 - ClassNotFoundException:CTTextParagraphImpl$1RList
Summary: ClassNotFoundException:CTTextParagraphImpl$1RList
Status: RESOLVED DUPLICATE of bug 53925
Alias: None
Product: POI
Classification: Unclassified
Component: XSSF (show other bugs)
Version: 3.8-FINAL
Hardware: PC All
: P2 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-24 04:12 UTC by zhyang
Modified: 2012-10-10 15:46 UTC (History)
0 users



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description zhyang 2012-09-24 04:12:33 UTC
OPCPackage pptPackage = OPCPackage.open(fis);
			
XMLSlideShow xmlSlideShow = new XMLSlideShow(pptPackage);
XSLFSlide slides[] = xmlSlideShow.getSlides();

for (XSLFSlide slide : slides)
{
	CTSlide rowSlide = slide.getXmlObject();
	CTGroupShape gs = rowSlide.getCSld().getSpTree();
	List<CTShape> shapes = gs.getSpList();
	for (CTShape shape : shapes)
	{
		CTTextBody tp = shape.getTxBody();
		if (null == tp)
		{
			continue;
		}
		List<CTTextParagraph> paras = tp.getPList();
		for (CTTextParagraph para : paras)
		{
			//CTRegularTextRun[] textRuns = para.getRArray();
			List<CTRegularTextRun> textRuns =para.getRList();
			for (CTRegularTextRun textRun : textRuns)
			{
				content.append(textRun.getT());
			}
		}
	}
}
///////
When the code run to the line:
List<CTRegularTextRun> textRuns =para.getRList();

There throw an exception:

Caused by: java.lang.ClassNotFoundException: org.openxmlformats.schemas.drawingml.x2006.main.impl.CTTextParagraphImpl$1RList
	at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
	... 2 more
Comment 1 Nick Burch 2012-09-24 09:33:06 UTC
Please see the FAQ for why this is happening, what a short term workaround is, and what the long term fix is. http://poi.apache.org/faq.html#faq-N10025
Comment 2 Yegor Kozlov 2012-10-10 15:46:15 UTC

*** This bug has been marked as a duplicate of bug 53925 ***