Bug 54016 - Unexpected record type (org.apache.poi.hssf.record.DConRefRecord)
Summary: Unexpected record type (org.apache.poi.hssf.record.DConRefRecord)
Status: RESOLVED FIXED
Alias: None
Product: POI
Classification: Unclassified
Component: HSSF (show other bugs)
Version: 3.8-FINAL
Hardware: PC Windows XP
: P2 normal (vote)
Target Milestone: ---
Assignee: POI Developers List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-17 06:03 UTC by rvandersanden
Modified: 2012-10-30 00:32 UTC (History)
0 users



Attachments
Spreadsheet that cannot be read by POI 3.8. (961.50 KB, application/vnd.ms-excel)
2012-10-17 06:03 UTC, rvandersanden
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rvandersanden 2012-10-17 06:03:04 UTC
Created attachment 29491 [details]
Spreadsheet that cannot be read by POI 3.8.

A RuntimeException occurs reading the attached spreadsheet.

java.lang.RuntimeException: Unexpected record type (org.apache.poi.hssf.record.DConRefRecord)
	at org.apache.poi.hssf.record.aggregates.RowRecordsAggregate.<init>(RowRecordsAggregate.java:107)
	at org.apache.poi.hssf.model.InternalSheet.<init>(InternalSheet.java:208)
	at org.apache.poi.hssf.model.InternalSheet.createSheet(InternalSheet.java:163)
	at org.apache.poi.hssf.usermodel.HSSFWorkbook.<init>(HSSFWorkbook.java:296)
	at org.apache.poi.hssf.usermodel.HSSFWorkbook.<init>(HSSFWorkbook.java:248)
	at org.apache.poi.hssf.usermodel.HSSFWorkbook.<init>(HSSFWorkbook.java:192)
	at org.apache.poi.hssf.usermodel.HSSFWorkbook.<init>(HSSFWorkbook.java:327)
	at org.apache.poi.hssf.usermodel.HSSFWorkbook.<init>(HSSFWorkbook.java:308)
Comment 1 Yegor Kozlov 2012-10-26 12:22:34 UTC
Fixed in r1402482. I included your sample in our collection of test files.

Yegor
Comment 2 rvandersanden 2012-10-30 00:32:26 UTC
I have tested this and confirm that the problem is fixed.  Thanks for your support.